UART Baud rate settings


#1

:unamused: Hi, I switched the baud rate of the chipset from 4800 to all possible values(all these in DEBUG mode). I could see the baud rate changing using the Auto detect option in Target monitoring tool it worked fine.But after changing the baud rate i tried to give the AT commands using Hyperterminal, but i got some junk values every time(these junk is different for diferent At commands).Please someone solve this for me.

Also, In Terminal emulator auto detect checks against only 600 , 9600 , 115200…how can i configure it to other values.


#2

I can’t help, because I stopped using TMT and Terminal Emulator a long time ago. But for anyone able to help you it would be critical to know which version of the tool you are actually using!

Best Regards,
Jan


#3

Sorry yaar i forgot to mention it…its 657c09 3.15 open AT version… I got it solved…The problem was i cant do it in debug mode… i can do it only in target mode


#4

Maybe you forget to exit properly from debug and the module was still in debug ( some sort of multiplex ) mode?

preferences->settings->misc

Cheers,
tom