TWS config error


#1

HI, I am having issues with the BC127 tws feature.

I am just trying to connect a master BC127 to a slave BC127 right now.
The devices have no problem seeing each other in a tws only inquiry but I get a 0x0011 error when I try to connect in either direction.

The config results are below.

Thanks for any help,
Calvin

here is the config from the master unit:
AUDIO=1 1
AUDIO_ANALOG=15 15 1 OFF
AUDIO_DIGITAL=0 48000 64 180210 OFF
AUTOCONN=0
AUTO_DATA=OFF OFF OFF
BALANCE=100 100
BATT_CONFIG=ON 145 4250 1500 200
BC_SMART_CONFIG=68E3 28F0 89F7 D93C
BEACON_DATA=0 00 11 22 33 44 55 66 77 88 99 AA BB CC DD EE FF 04 D2 16 2E EE
BLE_CONFIG=0 OFF 40 ON
BLE_CONN_PARAMS=128 12 6 40 0 400 50 400 400 61 400 400
BT_VOL_CONFIG=A A 10 1
CLASS_1=OFF
CMD_TO=20
COD=240404
CODEC=6 ON
CONN_TO=0
DEEP_SLEEP=OFF
DEVICE_ID=0001 0002 0003 0004 0005 0006 0007 0008
DISCOVERABLE=1 0
ENABLE_BATT_IND=ON
ENABLE_CAPSENSE=OFF
ENABLE_LED=ON
ENABLE_SPP_SNIFF=OFF 0 0 0 0 0
GPIO_CONFIG=ON 0 255
HFP_CONFIG=OFF ON OFF OFF OFF
HIGH_SPEED=OFF OFF
IAP_PARAMS=5 64 OFF
LOCAL_ADDR=20FABB04A9F3
MAX_REC=2
MM=OFF OFF 0 OFF OFF OFF OFF OFF
MUSIC_META_DATA=OFF
MUSIC_OLD_AVRCP=OFF
NAME=DigiBEAT
NAME_SHORT=DB1
PIN=0000
PROFILES=0 0 0 3 3 1 0 0 0 0 0 0
REMOTE_ADDR=000000000000
SPP_UUID=00 00 11 01 00 00 10 00 80 00 00 80 5F 9B 34 FB
SSP_CAPS=3
TWS_CONFIG=ON 0 0
UART_CONFIG=9600 OFF 0
USB_HOST=OFF
VREG_ROLE=1
OK

Here is the slave config.
AUDIO=0 0
AUDIO_ANALOG=15 15 1 OFF
AUDIO_DIGITAL=0 44100 64 100A00 OFF
AUTOCONN=0
AUTO_DATA=OFF OFF OFF
BALANCE=100 100
BATT_CONFIG=ON 150 4200 1500 200
BC_SMART_CONFIG=68E3 28F0 89F7 D93C
BEACON_DATA=0 00 11 22 33 44 55 66 77 88 99 AA BB CC DD EE FF 04 D2 16 2E EE
BLE_CONFIG=0 OFF 40 ON
BLE_CONN_PARAMS=128 12 6 40 0 400 50 400 400 61 400 400
BT_VOL_CONFIG=A A 10 1
CLASS_1=OFF
CMD_TO=20
COD=240404
CODEC=6 ON
CONN_TO=0
DEEP_SLEEP=OFF
DEVICE_ID=0001 0002 0003 0004 0005 0006 0007 0008
DISCOVERABLE=1 0
ENABLE_BATT_IND=ON
ENABLE_CAPSENSE=OFF
ENABLE_LED=ON
ENABLE_SPP_SNIFF=OFF 0 0 0 0 0
GPIO_CONFIG=ON 0 255
HFP_CONFIG=OFF ON OFF OFF OFF
HIGH_SPEED=OFF OFF
IAP_PARAMS=5 64 OFF
LOCAL_ADDR=20FABB04A9E8
MAX_REC=2
MM=OFF OFF 0 OFF OFF OFF OFF OFF
MUSIC_META_DATA=OFF
MUSIC_OLD_AVRCP=OFF
NAME=DigiBEATpa
NAME_SHORT=DBpa
PIN=0000
PROFILES=0 0 3 0 3 0 0 0 0 0 0 0
REMOTE_ADDR=000000000000
SPP_UUID=00 00 11 01 00 00 10 00 80 00 00 80 5F 9B 34 FB
SSP_CAPS=3
TWS_CONFIG=ON 0 0
UART_CONFIG=9600 OFF 0
USB_HOST=OFF
VREG_ROLE=1


#2

Hi bassmanbigc,

Can you advise the FW version you use on both BX127? Thanks.