TCP connection hangs up module network registration

Hi Everybody,

I have a problem using a MNVO (mobile network virtual operator) used in roaming, which choose the operator by itself.

Attach to GPRS works, but when I open a TCP socket (or during the TCP writing) the module stucks and it lost registration.
There is no solution to recover registration and I have to reset. I have tried to:

  • turn off radio (at+cfun=4) and turn on radio wothout reset(at+cfun=1,0)
  • disabling registration (at+wregc=1) and enabling again

but the module doesn’t reply. The rest of the application is still working, the module is just offline…

However, if I force to use another operator (different from the one that cause the problem), everything works as expected.

Does anyone expirence this situation?
Do you think is a problem of the operator?

Here is my configuraiton (I use Q26CL702):

“DWL”,“V08b13”,"",“Sierra Wireless”,55344,“111611 18:03”,“dda36757”,“00010000”
“FW”,“FW_SRC_747_8_F4_3.Q2687G”,“R7.47.4.201208311102.Q26CL702”,“Sierra Wireless”,2221264,“083112 11:02”,“6aa633a2”,“00020000”
“OAT”,“04.10.20140609095555”,“xxx”,“xxxxxxx”,636768,“060914 09:56”,“f21706f5”,“00260000”
-“Developer Studio”,“”
-“Open AT Application Framework package”,“”
-“Open AT OS Package”,“”
-“Firmware Package”,“”
-“ExtendedATApplication Library Package”,“”
-“Internet Library Package”,“”

Thank you.

Probably, it is linked to the network.
For analysing it, we might be needing some traces and logs…
I would suggest you to coordinate with your FAE/Distributor to raise a ticket with Sierra wireless. They will probably help you.

Just for info :

What is your application doing exactly? creating a socket and sending and receiving data?
I believe this issue is 100% reproducible. Is it?
not much idea about MNVO, but you said that it automatically chooses operator. So, may be it is latching on some other operator which has less signal strength.
Quite old module… we would be happy to help you. Could you please check with your distributor so that he can come up creating a ticket with sierra wireless for you?


Hi Rex_Alex,

thank you for reply.

The application opens a TCP socket using the API of WIP_OpenAT library and it sends and receives some data. I can reproduce the issie.

We have many other modules which works with the same applications, but today we receive another
customer highlight that have the same problem (and the operator is not a MVNO). If call and sms are used everything is good. The first time the GPRS is used and TCP socket is opened, the radio stuck…

I have also tried to connect using the WIPAT_Command and the problem comes up again. So I don’t think it is a problem of the application since we have hundreds of device working correctly.

Could I directly open a ticket to sierra? How to do it?


may be it’s not latching to the operator… very difficult without analysing the traces… you have to contact your distributor… do u have one? if not, let me know please… are the devices on field?? deployed?

Hi Rex_alex,

If it is possible to contact Sierra directly it is better, since FAE and sales representive of the distributor left the company and I don’t have other contact.

The devices are not on field, the customers has sent back them, so I can test the devices.

Let me know the level of traces you need for debug. If you have a link that explains how to dump correctly the traces please send me, because it is the first time I do it.

Thank you for support.

Best Regards,
Davide Tasca

PM-ed you!


The issue will now be follow up with the SWI/Distributors.