Spell checker


#1

I like the integrated spell checker for comments and strings, but it won’t let me add any words to the dictionary.

When I hover over a word that’s highlighted as misspelled and click on the option to add the word to the dictionary, I get a message saying “A user dictionary is needed to add words. Do you want to configure it now?”. If I click yes I’m taken to the spelling options page. On this page, the only option is to enable or disable the spell checker, with a message underneath that says “The selected spelling engine does not exist”.

Is this a bug, or do I need to install something extra to make this work?


#2

i also noticed this behaviour. never looked into a solution. but i suspect you can find one in the eclipse forums or faq?


#3

I guess there is a bug there… This is working correctly with a normal Eclipse + CDT installation, but not in M2M Studio :frowning:


#4

Found the fix:

http://stackoverflow.com/questions/48390/eclipse-spelling-engine-does-not-exist


#5

In m2m studio 1.1.1 the line is no longer in the preference file. However simply adding it works aswell.


#6

So how does one actually get a working spellchecker - with custom dictionary - in M2MStudio?

Will this be built-in in some future release?

I would be good if Wavecom would supply a default custom dictionary that, at least, included the word “Wavecom” :exclamation: 8)


#7

I did this (copied from the link above more or less):

  1. Export your Eclipse/M2M preferences (File > Export > General > Preferences).
  2. Open the exported file in a text editor.
  3. Add the line /instance/org.eclipse.ui.editors/spellingEngine=org.eclipse.cdt.internal.ui.text.spelling.CSpellingEngine at the end
  4. Import the preferences back into Eclipse/M2M (File > Import > General > Preferences).
  5. If you now try to add a word, the spelling tab now allows you to specify a custom dictronary.

More for the list:
recompact
recompacting
callback
Watchdog


#8

We will investigate on that again for 1.2.0; can’t promiss for adding some words by default to the custom dictionary, but we will have a look :wink: