SMTP sender email address rejected by server


#1

Hi,
I’m trying to use a Fastrack Supreme with Wipsoft for FTP and SMTP.
FTP is working fine, I can upload and download files to our ftp server.
But I can’t get SMPT to work to send an email.

AT+WIPCREATE=6,1,“smtp.orange.fr”,25
is fine, I get the answer : +WIPREADY: 6, 1

then
AT+WIPOPT=6,1,2,61,"infos.algade@orange.fr" ( this is my sender email address )
OK
AT+WIPOPT=6,1,2,62,"infos.algade@orange.fr" ( this is my sender name )
OK
AT+WIPOPT=6,1,2,63,"***********@algade.com" ( here I put the recipient email address instead of ********* )
OK
AT+WIPOPT=6,1,2,66,“Test wavecom” ( message title )
OK
No problem either…

Then :
AT+WIPFILE=6,1,2
keeps returning +CME ERROR: 880
i.e. the sender email address is rejected by the server

I can’t figure out why the smtp server could possibly reject the sender email address I’m using. I tried several email addresses, I tried everything I could, but the error is the same : 880 !

Nota : Concerning software versions :
AT+WIPCFG=3 returns
WIP Soft v311 on Open AT OS v422
Feb 5 2008 14:39:02 WIPlib:v3a05 WIPSoft:v3a02

If anyone has an idea to solve this problem, please let me know !


#2

Are you sure that this server allows unauthorized SMTP access? And also that it allows relay mail.
Try send your mail to somebody on the same server. For example from receiver@orange.fr.


#3

Thanks for your help, this is much appreciated !

I have already tried to mail from someoneelse@orange.fr, I have the same error (880)

I’m not sure I get it right when you say “unauthorized SMTP access”, but I have several Orange accounts on Outlook working on smtp.orange.fr without using any username and password authentication to send emails, so I assume that a AT+WIPCREATE=6,1,“smtp.orange.fr”,25 command is ok with my Fastrack Supreme…

I still can’t see where the problem comes from…


#4

Ok. So it seems just a problem with WIP options. I’d love to help you, but my mail client runs on OpenAT (from inside the module itself)…


#5

The mystery gets growing …
I updated the Fastrack Supreme firmware to the latest version : R72a00
Then I downloaded the latest Wipsoft application : 5.00.2050

Now, the error is 881 : SMTP recipient email address rejected by server !!!
Whatever recipient address I try, the error is the same…

Does anyone manage to get this Wipsoft application working to send emails ???

Is there any way to get tech support from wavecom ?
(No, I cannot get tech support from my supplier…)


#6

Don’t know what to think…

If I use "toto@orange.fr" or "test@orange.fr" as a sender e-mail address, it’s working. The mail is sent and I receive it on my mail address.

If I use “infos.algade.com” as a sender e-mail address (my company’s e-mail address), it’s not working and the error is 881, i.e, “Recipient address rejected by server” !!!

And in both cases, the recipient address is the same !

Would there be any maximum length or forbidden characters in the sender email address ?

I can’t figure out wether it’s a Orange SMTP problem or if it’s a bug in Wipsoft, or if there is something that I missed or did not understand…

Any comments, ideas, suggestions… ?


#7

Why don’t you swap fields with recepient and sender’s adresses? And repeat your experiments with another mail server.


#8

After a lot of tests, I came to the following conclusions with firmware R72a00 and Wipsoft 5.00.2050 :

  • With smpt.orange.fr :
    If the sender address is on the same domain name (orange.fr) than the smtp, the smtp server checks the existence of the sender address. If the sender address does not exist, it returns an error.
    If the sender address is on another domain name than the smtp, the smtp server does not check the existence of the sender address. Any dummy sender address can be used (spammers paradise…)
    The smtp server accepts any recipient address, on any domain name.

  • The error codes returned by the fastrack are often false. For example :
    An email from existingaddress@orange.fr to recipient@orange.fr works fine
    An email from nonexistingaddress@orange.fr to recipient@orange.fr (same recipient as above) returns an error “recipient address rejected by server” (!?!?)
    I cannot tell wether it’s the Orange smtp server or the Wipsoft application that returns incorrect error codes.
    This is one of the things that led me to false tracks and caused a lot of trouble to me to understand what was wrong.

The only problem that remains unsolved to me is that I cannot connect to a SMTP server that requires authentication.
I tried gmail and yahoo with several ports but the fastrack is unable to connect.
I cannot find in wavecom datasheets wether the fastrack supreme with Wipsoft supports SSL connexions to smtp servers. I assume I should start a new topic for this question.

I will keep this topic up to date if I got any new data, in case it can be helpful to anyone.


#9

Gmail requires SSL to connect. It is almost impossible to acheive when using only WIP. Probably with security plug-in this can be done. But it is easier just not use Gmail.


#10

Dear all…

We at TDC think that the solution to this problem has been found…

Here is the origional syntax as decribed by “algade”…

AT+WIPCREATE=6,1,“smtp.orange.fr”,25
is fine, I get the answer : +WIPREADY: 6, 1

then
AT+WIPOPT=6,1,2,61,"infos.algade@orange.fr" ( this is my sender email address )
OK
AT+WIPOPT=6,1,2,62,"infos.algade@orange.fr" ( this is my sender name )
OK
AT+WIPOPT=6,1,2,63,"***********@algade.com" ( here I put the recipient email address instead of ********* )
OK
AT+WIPOPT=6,1,2,66,“Test wavecom” ( message title )
OK

This is how to fix it…notice the <> encapsulating the address fields…

AT+WIPCREATE=6,1,“smtp.orange.fr”,25
is fine, I get the answer : +WIPREADY: 6, 1

then
AT+WIPOPT=6,1,2,61,“infos.algade@orange.fr” ( this is my sender email address )
OK
AT+WIPOPT=6,1,2,62,“infos.algade@orange.fr” ( this is my sender name )
OK
AT+WIPOPT=6,1,2,63,"***********@algade.com" ( here I put the recipient email address instead of ********* )
OK
AT+WIPOPT=6,1,2,66,“Test wavecom” ( message title )
OK

It would seem that the <> are not required for .com email addresses…
Let me know how you get on…

VBR
Adam


#11

TDC? Is that: tdc.co.uk/

:question:


#12

Yes… www.tdc.co.uk


#13

Thanks for your advice on this matter, I hadn’t thought about using “<>” characters for the addresses.

Unfortunately, it’s not working in my case :

AT+WIPOPT=6,1,2,61,“infos.algade@orange.fr” ( this is my sender email address )
OK
AT+WIPOPT=6,1,2,62,“infos.algade@orange.fr” ( this is my sender name )
OK
AT+WIPOPT=6,1,2,63,"***********@algade.com" ( here I put the recipient email address instead of ********* )
OK
AT+WIPOPT=6,1,2,66,“Test wavecom” ( message title )
OK

Then
AT+WIPFILE=6,1,2
returns +CME ERROR: 881

(notice that the error was 880 without the “<>” characters :unamused:
880 is “sender address rejected” and 881 is “recipient address rejected”)

I also tried to use “<>” characters only on the .fr sender address and not on the .com recipient address and I still got an 881 error.

Anyway, this is not really a problem according to the conclusion I posted on Dec 18, 2008.
I can get my application to work properly, as long as I’m very careful about the e-mail addresses I use.


#14

Hi Algade… my mistake… try removing the <> from the .com address… it should work then!.. I said that at the bottom of my origional post but accidentally put the <> in the field!?!

Cheers
Adam


#15

Hi !
I already tried removing the <> from the .com address :

Really strange, isn’t it ?


#16

Hi,

I’m using a Q24 Plus WCPU and my current version of the OS and WIP are the following:

WIP Soft v311 on Open AT OS v314
Dec 13 2007 10:56:52 WIPlib:v3a05 WIPSoft:v3a02

I’m able to open TCP and UDP sockets and even send PING commands. However, I’m failing each time I try to connect to my smtp server.

For debug sake, let’s consider the same server as you have been using.

I’m getting everytime this error: +CME ERROR: 3. I’ve tryed everything I could imagine. I have the bearer openned, however the WIPCREATE command fails when using SNMP.
It also fails on HTTP and FTP.

Could you help me? Is this something to do with the OS version?

Regards!


#17

Did you check that you have this commercial feature enabled on your device?


#18

Hi,

The WCFM command asnwers me with “0006,0”, however I don’t know what this means :frowning:
Where can I find that information?


#19

Did you use “AT+WCFM=2” or “AT+WCFM=3

Did you check the AT Command Interface Guide?
the chapter about WCFM tells you the options and also how to decode the result


#20

Yes, I’ve used the AT+WCFM=2" command…result is “+WCFM: 0006,0”.

What I find in the AT command guide v6.57f in the WCFM command description is only:

[b]15.35.3 Defined values

0: disable some features of 1: enable some features of 2: display the features state

: features mask
16 bits hexadecimal string (4 characters from 0 (zero) to ‘F’)

: Password
256 bits hexadecimal string (64 characters from 0 (zero) to ‘F’)

0: the feature has not been modified since the last boot of the product. 1: the feature has been modified since the last boot of the product; a reset must be performed to take the modifications into account.

Note: If a feature is reset to its initial value after a modification, the
parameter will be reset to 0.[/b]

Based on this I can only tell that the reset flag is 0 and that the FtrMask is 0006. However, what are the bits this mask masks?

Thanks for the help :slight_smile: