SL8082T firmware I2C

I can’t get I2C working on my SL8082T, I believe this is because it has firmware package 7.52.2 installed on it. I wanted to upgrade the firmware to 7.53 but in Developer Studio 3 I cannot choose this firmware version (even though I installed the package on my PC). I figured perhaps I had to upgrade the bootloader first. It has ‘S4_1_0_21BT R2371 CNSHZ-ED-XP0031’, which I tried upgrading to ‘B04.05.18.00.SL8RDBT R2509 CNSHZ’ but this upgrade keeps failing.

How can I upgrade my SL8082T’s firmware to 7.53?

did you try with the .exe file?,-d-,53,-d-,1,-d-,a1-for-sl808xt_bt/


Hi Alex,

I tried it with the binary updater, but it says it can not find my modem. I have it connected to a serial COM port (USB to serial converter). I’m using 2-wire communication. The binary updater also does not give me the option to select which COM port to use.

Developer Studio does not give me the option to update it with 7.53 so I figured that I might need to update the bootloader first. I tried this, but when the XMODEM transfer reached 99% the modem returned ‘ERROR’. The module is still working and I can update the Open AT application, but no luck with the Firmware.

Binupdater should be used with the USB interface. Do you have it available?

No I don’t have it available. Is there another way?

Did you try with .dwl file through hyperterminal?
You can issue AT+WDWL command to let the modem into download mode then transfer the .dwl file using 1K Xmodem protocol.


I have tried downloading the DWL with a terminal and XMODEM transfer. The progress remains stuck at 0%.

Also when I attempt to download Firmware 7.53 from the Package Manager view in Developer Studio, it tells me this firmware is not compatible with my embedded module (SL808x), even though it is actually an SL8082T (Target management confirms this).

Even I tried and ended up same :frowning:
Seems like have to contact sierra technical support…


Thank you very much Alex! I’m looking forward to hearing from you again, when the technical support has responded. It’s an urgent matter to me, so I’m glad you haven’t forgotten me :slight_smile:

Kind regards

On a side note:
I wanted to try upgrading the firmware over AirVantage, I added the 7.53 firmware version from the public repository to our own but when I tried to upgrade my device it said the binary packages were missing.