SL8080T UART to an application host microcontroller


I am trying to connect the SL8080T module with an NXT microcontroller via UART, but im encountering some difficulties.

I already wrote and tested the AT command script for my application using the SL Series development board connected to my PC with an USB cable. (Almost) Everything went well.

Now I have some difficulties to use the UART pins from the Development board. For information The NXP controller have a 3.0V logical level on its UART pins, according to the information I found on the forum, the SL8080T has 3.0V tolerance on its UART pins.

Then I wired:
1 -the TX pin of the NXP controller with TP 34 (UART1_TXD)
2- The RX pin of the NXP controller with the TP 32 (UART1_RXD)
3- The GND pin the NXP controller with the TP35 (GND)
4- I use a scope to watch the TX signal out of my controller (corresponding to an “ATI9” message)
5- Using the same scope, I can’t see the response for the “ATI9” I’m sending (the TP 32 stays on logical high)

/Basically when the TX pin of the first device must be connected with the RX pin of the second device. But I learned from the reference document below, that UART pins’ names was assigned considering the Host direction. In fact, UART1_TXD is an input and UART1 RX_D is an output.
There is anything I have to set on the development board (switch?soldering?) to enable UART1 signals on the Test Pins?
Is the Flow control required for this operation? (CTS/RTS?)
Is the UART signals can be seen on TPs when using USB cable for serial communication? Actually I tried with the USB unpledged but the result was the same

Thanks for help


Are you using Sierra dev.kit for SL8080T? In which SL8080T’s UART is routed to UART2 port on dev.kit.
Please refer to user guide for detail:

Also, have you tried to communicate with UART port via PC?

For info
Flow control can be configured using AT+IFC, by default CTS/RTS required.
UART and USB signal can be work at same time.

Hope it helps.


This user guide describes another version of the SL dev.kit. Actualy I picked up the information from this document:

For information, I can’t disable Flow control using AT+IFC. After sending AT+IFC=0,0 the Uart still need an RTS/CTS to receive and send frames.

It takes me a logic debugger on the physical port to properly understand how does the Uart communication works. Anyhow, I solved this problem. I wonder what is next :slight_smile:

Thanks for help,

Hi Yaeli,

Can you tell me how did you get the UART work with your host processor?
Have you able to turn off the hardware flow control and use only rx and tx lines?

Which test pins of the SL dev kit have you connected to the host target uart?



I am not sure why +IFC=0,0 does not disable hardware flow control for you.
Are you using outdated FW version?
In my case, with +IFC=2,2, I have to turn on RTS to get response. After configured +IFC=0,0, I can turn off RTS.

Anyway, one quick workaround maybe to short RTS and CTS pin if it is not supported by the MCU.
Maybe you can try?