Sim cards stopped working, no connect

This may be related to my last question in which I thought soldering temperature damaged the module.

About my first prototype with an HL7800-M module. Firmware is latest I have 3 SIM cards from the same M2M sim card company. Two of the cards worked and connected immediately. AT+COPS reported the operator T-Mobile. A 3rd card for some reason connects though AT&T, and takes up to a minute before it decides to connect.

I just built 2 new HL7800-M prototypes on a new PCB version. All the relevant wiring is the same. Firmware is latest Suddenly the 2 cards that had worked do not connect. The 3rd SIM that reported as AT&T still delays before connecting, but AT+COPS now says the operator is name of the SIM card vendor instead of AT&T as before.

I have an RF probe connected to an oscilloscope with which I can tell when the module transmits. With the 2 similar SIMs the HL7800 never transmits. Apparently these SIMs never attempt to connect. AT+COPS? result 0 (not searching).

I know the hardware is working because with the 3rd SIM there is a big transmit signal when it eventually decides to connect. Both of the new prototypes work similarly with all SIMs. Unfortunately I cannot compare to the first prototype because I used those parts for one of the second prototypes. See my last post " HL-7800 Easily Damaged By Soldering?" They may not have been damaged by soldering. They just stopped working with the 2 SIMs.

I have a TELIT cellular module UE866 in which all SIMs still connect immediately and COPS still shows the original AT&T and T-MOBILE operators. So I don’t think there is anything wrong with the SIMs.

Debug initialization output seems the same between working and non working SIMs. One thing I don’t understand is at the end of initialization there is always a line or two of “[CRI] Fail to send At respond”.

Output of some commands:
+KBNDCFG: 0,0000000000000A0A188E+KBNDCFG: 1,0+KBNDCFG: 2,0
+KBND: 0,00000000000000000000

After the 3rd SIM connects this command result shows a band:
+KBND: 0,00000000000000000800

I just tried a brand new SIM card from the same SIM vendor. It connected immediately. It seems that 2 old SIMs stopped working in the HL7800 at a point in time although they still work great in the TELIT module. And the point in time they stopped working was when I was assembling and testing the new PCB prototype version.

Hi Garrick,
Could you help to un-plug the power of HL7800 over 3 minutes and then try those SIMs again?
Please send these commands and send us the output:

  • ATI9
  • AT+CEREG=2
  • AT+COPS?
  • AT+COPS=?

And for the KBND command, it only shows the current band that the device is registered to network. It means that if the device does not register successfully, KBND command will show 0 value.


Here is the results. Also the SIM provider has some ideas.

2020/04/10 18:01:58
IMEI-SV: 3594160956057809
Legato RTOS: 18.09.4.ALT1250.rc3 2020/03/02 10:50:25
atSwi: 30.00
UBOOT: 01.03
Apps: RKAPP_02_01_02_00_80__b8247bc6f15eaf43cfdf7605486de028995374aa
MAC: ALT1250_02_01_02_00_81_FW
PHY: 12.50.228224


+COPS: 0

+CGDCONT: 1,"IP","xxxxxxxx",,0,0,0,0,0,,0,,,,,+CGDCONT: 2,"IPV4V6",,,0,0,0,0,0


The SIM provider has some advice,

However, as xxxxxxxx SIMs are able to roam onto multiple networks, this may result in some unexpected behavior with certain modules, as well as when testing the same SIM across different modules.

In particular, while xxxxxxxx provides roaming connectivity on both AT&T and T-Mobile in the United States, LTE Cat-M1 service is only available with AT&T at this time. As a result, if your HL7800M module does not support 2G fallback, it will only be able to connect to AT&T, and it may therefore have trouble using the “cached” T-Mobile connection. In some cases, even if it supports 2G fallback, it may have trouble switching to AT&T in order to establish Cat-M1 connectivity.

You may need to manually select the AT&T network using the following command:


That command returns “+CME ERROR: 515” (Device busy or Invalid Character in string)

I’ve tried Preferred PLMN List "AT+CPOL=1,2,“310410"”
It returned “OK”. I reset it but it still does not try to connect.

Hi Garrick,
This is roaming SIM for AT&T, so could you help to try to set LTE of AT&T band only?
ex: AT+KBNDCFG=0,800 ( the band of the third SIM is registered successful)
Make sure that the APN is correct
Reset device: AT+CFUN=1,1 and wait some minutes, then check:

  • AT+COPS =0
  • AT+COPS=?
  • AT+COPS?


1 Like

Note: I have set CREG and CEREG to unsolicited report changes.

+CEREG: 2,3

AT+KBNDCFG: 0,0002000000000F0F1B9F


+COPS: ,(0-3),(0-2)

+COPS: 0

Hi Garrick,
It looks like your device does not search any network.
Please help to check the antenna, make sure that it is plugged.
And please contact your SIM provider to check the correct APN.
And set fewer supported band (as previous comment) to see the device could register to network or not.


I did send the command AT+KBNDCFG=0,800 and it replied “OK”
I rebooted with AT+CFUN=1,1
But the AT+KBNDCFG? still replies the same as above.

Note that CEREG output says registration denied.

This SIM and another will not register. An older card that is linked to AT&T registers, and a newly activated card will register, so I know the hardware is working. I am working with the SIM vendor also. I may just buy new SIM cards and save everyone’s time. But it would be good to understand this mystery.

Well this is new. I just tried the command above the SIM vendor suggested and instead of giving and error it said OK. It immediately auto-registered. I have another non registering SIM and I will go over the steps to see if I can find exactly what step fixed it.

1 Like

Steps to solve the problem

  1. As per above direction:


  2. Reboot:


  3. See AT Coimmand Reference and also
    This must be done to enable step 4.


  4. The 310410" in the next command is my PLMN which is the combination of my MCC and MNC. This will force the module to register to my local AT&T network.

    Look up the numbers of your local network.

    This fixes the original problem was caused by using this SIM in another module that did not use LTE Cat-M1, and the SIM had cached a network that was not capable.


    The module should now register with the network

  5. Restore the network registration to automatic.


  1. Also I re-enabled the previous band mask for roaming and if another network uses a different band. The SIMs continued to connect normally after I did this. Read available bands:


    Use the result of that command to set bands

    AT+KBNDCFG=(result of last command)