Sierra XM1110 modules firmware upgrade fails and PGMC commands no longer accepted

I have a new batch of Sierra XM1110 modules. Unlike what the data sheet says (default 115200 baud rate), this time the ones I have are 9600 baud. So I tried a firmware upgrade like I did before. But no matter what I do, the DA progress shows a full green progress bar but the ROM process immediately stops stating that an error has occurred during the download. ‘Please check download settings’. Also the PGCMD commands are not accepted by the module. PMTK commands do work so the communication with the module works OK. Please advice. Thanks.

Hi allard vanw ,

On FW 5.1.1 , the default baudrate is 115200 and PMTK251 command is disabled. Which firmware are you using and where did you get the new firmware?

On your current FW, it seems that PMTK251 is enabled, Could you change the baudrate to 115200 and do the firmware upgrade again?


When querying the firmware version I get: $PMTK705,AXN_2.32_3337_15010801.0000,*2D
Baudrate is 9600 of purchased module.
I use download agent ‘Download_agent_MT3333.BIN’ and ROM ROM_AXN5.1.1_8523_3333_1152.1151100.1.bin
Both versions I got from the Sierrawireless internet site
DA Progress bar is running OK to 100% directly followed by 'Warning please check download settings!
When I change from 9600 to 115200 baud using PMTK251,115200 I get the same result. OK DA progress bar, no ROM progress bar, download settings warning and download result: DA responded with an incorrect sync character.
The firmware in my product makes use of PGCMD commands sent to the GPS module, none of which appear to be working any longer as the modules do not respond to them.

I am truly at a loss why Sierra keeps changing the firmware with every batch of these modules I purchase. It drives me and my customers nuts as I have to deal with special firmwares for my own project, which becomes a administrative nightmare. What is the reason behind? I mean, changing stock baud rates all the time (meanwhile I got 9600, 38400 and 115200) wouldn’t qualify for a repair of faulty firmware would it?
I do hope this issue can be fixed as now I’m stuck with 9600 and desperately need 115200 firmware.
regards Allard