Sierdoesn't workra Skylight

I have a Dell Latitude E6530 laptop.
I installed Sierra MC7304.
There is internet, but very low speed.
And Skylight doesn’t work.
How can this be fixed?

does the latest FW have improvement?

Did you install the latest USB driver?

I saw that other user can make it work with skylight:

Connected, but very low speed.
Снимок экрана 2024-04-07 200818

does the latest FW have improvement?

Seems the signal is not good
Did you connect two anteanna?

Reinstalled - it worked.
Only it will be identified not as a modem, but as a network adapter.
Is it supposed to be like this?
Сетевой адаптер

modem will be using PPP dial up, the network adaptor probably is using RMNET interface

How can this be configured? After all, in this form, I do not have COM, and I cannot access AT.

See if this helps to reinstall the driver with configuration.ini

I don’t quite understand. I downloaded the file .ini
And what needs to be done next?

you can open Configuration.ini and change “USBCOMP=8” and run the driver setup again

Nothing has changed.

have you run the driver again?
Have you reset the module?

BTW, see if this helps:

Yes, of course
of course rebooted

other user can make it work on MC7304:

You can also try in linux:

That didn’t help either!!!

have you tried in linux?

Linux does not have an option at the moment

what option are you talking about

Sorry, I didn’t understand what you were talking about…

Do you mean you don’t have linux to test?