Set XA1110 to 10hz


#1

I bought from you 6pcs of XA1110, they came configured set to 115,200 bps from the default 9600bps, I’ve put a battery at the output of VBACKUP lithium3V and with the commands i can configure the gps to 10hz but after i turn it off it goes back to 1hz, please send me a firmware with which i can permanently set it to 10hz without it going back to 1hz. This happens to all 6 GPSes i bought from you.


#2

Hi,

Could you please provide more details about the way you change the NMEA output rate and also the FW version? Thanks.


#3

I used the command: $PMTK220,100*2F; but tried setting through “MiniGPS” and “GPS-viewer_ v1.7”… After that the NMEA data starts running at 10hz but after turning the power off it resets back to 1hz, 8pin VBACKUP is powered at 3V from a lithium battery, but the data isnt saved in the static RAM, all 6 GPSes I tried flashing with firmware from your site, version UART-I2C but there’s no change, maybe there’s a hard coded configuration forbidding VBACKUP?


#4

Hi,

PMTK command does not save configuration into flash. Please use PGCMD command if you want to retain your setting. You can check PGCMD,233 to see if this meet your requirement.


#5

I tried the command $PGCMD,233,3*5D through RealTerm GPS and it got to 10hz but after removing the power supply it’s again back to 1hz, isn’t there a firmware that can hard set it to 115200/10hz?


#6

Hi,

The FW version you use should be working for saving the setting.

Please use following command to set the NMEA output to 10Hz.
$PGCMD,233,3*5C

If command accepted, you will see the following response.
$PGACK,Command_vaild*1C


#7

OK,
It worked !!
Thanks!!