Sending AT commands thru ATCOM in WP7702 using raspberry pi

Hi all,

I installed atcom in my raspberry pi to send ATcommands to my WP7702. installation was successful.

here’s the command i used: atcom -p /dev/ttyUSB2 AT!ENTERCND=“A710”

but i got this error: bash: !ENTERCND=“A710” : event not found.

please help

the password should be “A710”

my bad. it’s a typo. it should be A710.

have you connected the WP77 to Ubuntu PC with qcserial driver to enter AT command with minicom?

@jyijyi , i’m using raspberry pi. and i’m using ATCom for sending AT commands. here’s the reference link for the atcom.

i never used rasberry pi, but you can verify if your WP77 is working fine with Ubuntu PC first

yes. WP7702 is working. i tried sending AT commands using shh and then microcom /dev/ttyAT and it was successful.
however, i want to automate sending AT commands in raspberry pi command line. Is that possible?

have you verify the USB driver of your rasberry pi is OK or not?
“echo” and reset command AT!RESET to /dev/ttyUSB2, will it make the module reset ?

tried the command: atcom -p /dev/ttyUSB2 AT, it will have the reply “OK”.

but when i tried the whole at command, atcom -p /dev/ttyUSB2 AT!RESET
same result. bash: !RESET: event not found.

how about AT+CFUN=1,1 to reset the module?
i guess it is causing by the “!”

AT+CFUN works… However, when i tried the AT!ENTERCND=“A710”, it will give an ERROR.

maybe atcom does not accept “!”

maybe. do you have any idea how to send AT commands aside from atcom?

I used minicom in Ubuntu PC

can we do ATCommands automation using the minicom?

i think it can run some script with minicom

1 Like