At commands not working

Hello All,
I am having the development kit and I am using WP7104 series module
I am trying for the board bring up .
I followed the proper hardware setup as mentioned in the user guide .
I am trying for the basic communication test i.e ringing test as mentioned in the user guide document .

I am sending the AT commands in minicom . But I am not getting any kind of reply for that.
kindly let me know where I am going wrong

On which port are you sending the AT commands?

Hello krima ,
thanks for the reply .
I am trying to send the AT commands by minicom …
i AM NOT GETTING ANY REPLY FOR ANY AT COMMANDS

Regards
Shruthi

Are you using UART or USB?

I am not sure what is default but I think UART is not AT command by default, instead it is used for a linux console. Using USB should work with AT commands. You just have to find the proper ttyUSB* device.

Hello Krima ,

Thanks for the reply .

I have tried to check the proper ttyUSB* device but i am facing problems in doing it properly .
i went though various websites as how to configure the USB . But couldnt make it.

kindly can u give me a proper procedure as how to set the ttyUSB * in minicom .

Regards
shruthi Pawar

First check that you have the USB driver installed in your Linux host. If you do you should see something like this in dmesg when you connect the WP.

[3182541.605059] usb 1-2: Product: WP7104
[3182541.605066] usb 1-2: Manufacturer: Sierra Wireless, Incorporated
[3182541.605073] usb 1-2: SerialNumber: 0123456789ABCDEF
[3182541.628264] GobiSerial 1-2:1.0: GobiSerial converter detected
[3182541.628430] usb 1-2: GobiSerial converter now attached to ttyUSB0
[3182541.629295] GobiSerial 1-2:1.2: GobiSerial converter detected
[3182541.629450] usb 1-2: GobiSerial converter now attached to ttyUSB1
[3182541.633677] GobiSerial 1-2:1.3: GobiSerial converter detected
[3182541.633841] usb 1-2: GobiSerial converter now attached to ttyUSB2

The last ttyUSB is the AT commands port so in my case it is ttyUSB2.
Start minicom:

sudo minicom -s

Then you should see this menu:

+-----[configuration]------+                                     
            | Filenames and paths      |                                     
            | File transfer protocols  |                                     
            | Serial port setup        |                                     
            | Modem and dialing        |                                     
            | Screen and keyboard      |
            | Save setup as dfl        |
            | Save setup as..          |
            | Exit                     |
            | Exit from Minicom        |
            +--------------------------+

Go down to “Serial port setup” an push enter. Then you should see this menu:

+-----------------------------------------------------------------------+
    | A -    Serial Device      : /dev/ttyUSB2                              |
    | B - Lockfile Location     : /var/lock                                 |
    | C -   Callin Program      :                                           |
    | D -  Callout Program      :                                           |
    | E -    Bps/Par/Bits       : 115200 8N1                                |
    | F - Hardware Flow Control : Yes                                       |
    | G - Software Flow Control : No                                        |
    |                                                                       |
    |    Change which setting?                                              |
    +-----------------------------------------------------------------------+

Use ‘A’ button to change the device to the correct in you computer. Push enter until you come back to previous menu and then go down to “exit” and push enter. Now should be able to send AT commands.

Hello Krima ,

Thanks a lot for the reply …

It worked :slight_smile: :slight_smile: :slight_smile:

Thanks a lot for helping me out …

Regards
Shruthi

how do you check the usb drivers, which commands can you send to sierra modules and which port should be the nmea part?

do i also have to power on the antenna connector or smth? and how can i even use the Gps function in windows at all?

Dear @fordsierra1 ,
Before answering you question, can you please provide answer to the following items:

  • Which Sierra module are you using?
  • Which host OS are you using?

Thanks

7511, win and linux i have