RV50 Verizon Unable Connect remote web server

Application is connect to remote device with web server on port 80.
Wireless service is Verizon M2M public static IP (apn so01.vzwstatic).
The public static IP works, can access and configure modem on [ip]:9191.

Tried port forward WAN 80 to LAN 80 (static IP on remote device, port forwarding OK)
Also tried 8080 and 30009 WAN to LAN 80 (in case provider blocking ports)
Also tried DMZ which identified correct LAN IP for remote device.
Knowledgeable support at 2 different Sierra distributors say all looks good.

Testing connection with Telnet prompt (just to verify connection to specific port, not actually doing any telent which isn’t supported by remote device). When remote device ethernet connect to RV50, telnet page opens indicating connection, with cable disconnected telnet shows connection error.

Modbus TCP connection on port 502 works properly. No problems whatever! But browser connection will not pass any data.

I can browse to remote device web server through internet by placing it on a DSL line router (port forward WAN 80 to remote device [ip]:80, can then access remote device web server from another ISP no problem.

So, remote device web server works fine through internet, but not through Verizon/RV50. Vendor providing the RV50 and wireless service advises they use same for all sorts of web server devices on a regular basis. Bottom line everything seems right but no communication. Don’t know if it’s the remote device, the wireless service or the RV50 at fault?

My next step is sniff the TCP traffic between remote device and DSL internet ISP router (works) vs. remote device and RV50 (doesn’t work). Awaiting delivery of old school hub to enable wireshark on different LAN IP than the machine it’s running on.

Thought I’d try posting this mystery here in hopes someone can think of something I haven’t! (and hopefully to post the solution once I figure it out).

Hi mwaldrop,
In this case, please try to remove Port filtering-Inbound and Port filtering-Outbound lists in ACEmanager->Security tab. If this doesn’t work, please provide your configuration template file, ALEOS software version and Radio Firmware version.