RV50 OpenVPN routing problem

hello!

I have an RV50 and i have set up the OpenVPN tunnel with success (thanks to others in this forum, without their help i would not succeed). The WAN is a 3G connection, there is a wired device connected to the LAN port of the RV50. I am able to ping the both ends of the tunnel. I would like to route traffic over the tunnel to reach the host behind the RV50 (the wired device). This device has its default gateway set to the RV50s internal (LAN) IP (192.168.13.31)
The problem is: i can not reach the device form the OpenVPN server side. I can reach the server from the device, but not vice versa. The server has a route set up to send packets desired for 192.168.13.0/24 (RV50 LAN network), the packets enter the tunnel, but there is no response. The RV50 simply does not forward them to its LAN interface. I had FW 4.9.3 installed, i updated it to 4.9.13, but it does the same. I also tried NAT, but it does not NAT packets coming from the tunnel… Also it does not route traffic coming from the LAN into the tunnel when NAT is diabled in the OpenVPN settings. Is there an option i am missing? To me it seems, that packets coming from the tunnel gets dropped by some rule. I factory reseted the RV50, all port filtering is also disabled. I even tried to set the DMZ IP to the devices IP address, but the same happens. If You have any idea or suggestion, please share it.
Thank You!
regards,
Richard

Hi @lionsgi ,

I follow the link below to config OpenVPN server and successfully ping from both side. You can see the picture.


OpenVPN link:

It seems that it’s about your server configuration. Please make sure the following steps are correct:

  1. In config file at directory \OpenVPN\config\server.ovpn, 2 lines should be added
    client-config-dir ccd
    route 192.168.13.0 255.255.255.0
  2. At \OpenVPN\config\ccd, create file with name “client” and add route to the file:
    iroute 192.168.13.0 255.255.255.0

Note that: “client” is the name of Common Name at the steps that you generate certificates & keys for your gateway device, so you need to change the name accordingly.
3. Restart the tunnel.

Thanks,

If your question is answered, please help to mark Solution

hello Cherokee!

i just tried out Your suggestions and it works!
I was missing the “iroute” option. I knew somehow that the client is the point where the packets get lost, but i did not know why. I do not know why the client (RV50) does not know where to route the packets, he knows (should know) all routes… I basically do not understand, how the iroute option fixes this problem, because it configures the server AFAIK… I already added a static route by hand for 192.168.13.0/24 to tun0 before, and the packets (icmp ping) went into the tunnel (i checked this with tcpdump) but no answer packets came from the tunnel.

i tried it out earlier with this setup to put another openvpn client (a laptop with linux) onto the RV50’s LAN and it worked without iroute.

I am happy that it works now :slight_smile:
So thank You!
regards,
Richard