RV50 IP to Serial Configuration problems

Hello, I am trying to set up a project where the RV50 accepts TCP packets from a network device, and sends the data payload to a local serial device. It also should work the other direction, where the local device sends a serial command to the RV50, which will send out a TCP packet to the network device. I have followed the procedure located at the following link https://source.sierrawireless.com/resources/airlink/forum_topics_and_questions/configuring-ip-to-serial-with-auto-answer-and-serial-to-ipcore-developer/#Table3, but I am having trouble getting it to work as intended.

When I set the Startup Mode Default to “TCP”, serial commands from the local device are correctly received as packets from the network device, but packets from the network device are not received on the serial link by the local device. I checked the status, and the serial bytes sent does not increase in this case. I turned on firewall logging to make sure the packets were not getting blocked, and confirmed that the TCP packets were being transmitted as expected, with no dropped packets. The RV50 would respond with an ACK after each TCP packet was received.

When I set the Startup Mode Default to “Normal (AT command)”, the opposite is true. In this case, the local device correctly receives the data payload of the TCP packets from the network device, but the network device does not receive the data from the serial device. In the ACE Manager Status, both Serial bytes sent and received increase for this case.

I am using a USB cable connected to my PC as a virtual ethernet port so I can configure the device using ACE Manager, and a serial DB9 cable to connect to my local serial device. Is there anything else I can try to get this to work in both directions at the same time?


  1. Is the TCP Auto Answer Enabled?
  2. Is the RV50 IP routable? In other words, the IP address provided by the carrier routable over the internet?
  3. What IP/Port are you using to dial into the serial device?
  4. What firmware version is installed on the RV50?


Hello Jay,

Thank you for the reply!

  1. Yes, enabled TCP auto answer has been enabled.
  2. The IP address is routable, by special request to the service provider (Nimbelink).
  3., port 12345
  4. I need to check on the firmware version, I will get back to you later this morning.

Thank you,


Update on the firmware information.

ALEOS Software Version: 4.7.0
ALEOS Build Number: 027
Radio Module Identifier: VZW
Device Model: RV50
Radio Module Type: MC7354
Radio Firmware Version: SWI9X15C_05.05.58.01 r27044 carmd-fwbuild1 2015/03/05 00:02:40


Has a solution ever been found for this issue?
I seem to have the exact same problem with an RV50 running ALEOS 4.8.1
thank you

A solution was never obtained from Sierra wireless, working with their support has been a quite frustrating experience and we plan to investigate solutions from other manufacturers for future projects. However, we were able to find a solution on our own that satisfies our requirements, although it requires a somewhat lengthy delay to switch between modes. (2-4 seconds on average). What kind of application are you working on? If your project can tolerate this delay I might be able to help.

Do you have the Ethernet port enabled?
I had a similar issue with ALEOS versions 4.7 - 4.81. No issue with 4.5.2
With the Ethernet port disabled, somehow TCP PAD is broken on the serial port. Enable the Ethernet port and everything works fine. DHCP does not have to be enabled.
I worked with SW on this and they have fixed it for the next release which I am guessing is 4.9.0 ?
The last I heard is this firmware is scheduled for release before the end of the year.

I had a similar problem which was corrected by enabling the DMZ under the Security Tab. After 4.7 they changed the default settings to “Disabled”. In my applications I also ensure that I know what port number I’m sending/ receiving and set that port in the Serial configuration tab.

Thanks for the replies! I had tried it with the ethernet port enabled and disabled, didn’t seem to make a difference. If I get the chance I’ll try enabling the DMZ. I don’t have the radios anymore though so it might be a while. I did make sure I had the port numbers set in the serial configuration tab.