RV 50 Network Connection failed


#1

Hello, I am having a problem with the network connection of the RV 50. (Cellular state details: Data Connection Failed, Waiting to retry) and also it would not assign a IP address to the device (Cellular IP address: 0.0.0.0)

It seems the RV 50 device would not connect to my mobile carrier (the network & also signal LED would constantly flash amber/red, and sometimes the signal LED would be green or amber but the network LED would constantly be flashing red). At first, I thought it was the signal strength/reception, so I tried many locations; outside my house where the device had clear view of the sky, and also at my University. However, the problem keeps persisting.

I have two RV 50 devices, 1 with the updated firmware/radio modules, and the other with the factory firmware and settings. Both devices have the same issue.

I also tried using different carriers/SIMs on the RV 50, i.e BELL, Public Mobile (telus), and Rogers. These carriers work perfectly fine with my phone, however does not with the RV 50. And in AceManager it would show the correct phone number and that it is connected to 4G/3G LTE when using the different SIMS.

If anyone has a solution or could guide me on how to maybe fix this problem it would be greatly appreciated because I am doing an electrical engineering research project for University of Manitoba, and I need this device to work in order to proceed.

Thank you, I will be uploading pictures to further clarify what is happening