RTC on WP8548 is 1980

I asked this question awhile ago How to Persist Date/Time Across Watchdog Resets and I’m revisiting this issue.

When I run cm rtc I get a date of 1980 but when I run date I get the correct date in UTC. I have the VBAT pin connected to power on the module. According to the Legato docs the RTC is supposed to be updated by the modem but this doesn’t seem to be occurring even though the time TIME_SERVICES="qcom_time" line in /etc/time_service.conf daemon is not commented out.

Why isn’t the RTC being updated?

Ultimately my requirement is to have date/time persist across resets (watchdog, app or external). Power would be constant across the reset.


if you have set TIME_SERVICES=“qcom_time”, do you see the +CCLK changed after registering to network?

+cclk: “22/07/19,00:59:45+32”



I will run that command tomorrow and check the result. Is there something else I should check if that command doesn’t provide a result?


probably the network did not give the time to you.
you can check with the network operator.

@jyijyi When you say network operator do you mean our MVNO? Or the network we are connected to?

Sierra is our MVNO.


if the network did not give the network time indication, you might also try NTP



I ran at+cclk? like you suggested. I see an update but the RTC still shows 1980, see below.

+CCLK: "22/07/19,16:02:28-28"

root@swi-mdm9x15:~# cm rtc
18 Jan 1980 21:21:55


how about using le_clk_GetAbsoluteTime() or linux command “date”?

Or you can use “cm rtc set” command to set it.


I did a lot of testing yesterday and it seems like le_clk_GetAbsoluteTime() returns the same as date command. If the WP85 is powered on without an antenna it seems to restore the RTC value of 0 which is Jan 6, 1980 or GPS epoch.

The RTC still doesn’t get updated from the network time or GPS time so I think I’m going to do it manually.

On my side, if module can register network, I can use AT+CCLK? or “date” command to get the real time.

And yes, you can use “cm rtc set” command to set it.