Recommendation for syntax when adding AT commands

One of the key features of Open-AT is that it allows you to add your own, custom AT Commands.

But are there any recommendations for syntax when adding new AT Commands?

Siemens use the “AT^S” prefix for their custom commands;
Ericsson used “AT*E”
Wavecom used “AT#” for their internet stuff

ITU-T V.250 (formerly V.25-ter) formalises the definition of AT Commands - it just says that all “AT+” prefixes are reserved (so Wavecom ignored that with AT+WIND, AT+WOPEN, etc…)

What do people here use :question:

Hi awneil,

under OpenAT 3.0 and greater I’m using ‘AT+’-Commands for my own commands too, because I must handle the parameters of the commands myself if I using an other command prefix like ‘AT#’ or ‘AT-’ …

Regards,
Ralf

Nope. Only the AT part hast to be always the same.
I was using AT~… AT#… at+…, even AT###=1 for testing purposes works well. BTDT.

But, you are right for commands like MY+something, then you are in the trouble to write your own message parser.

Heinz

Should I have so wrongly understood the open RK manual? Thanks for explanation, I’ll try it the next time once more.

Regards
Ralf

Since I’m switching between OAT 3.xx and 4.xx I had a look in my source code…

Yes, I’m using at### for debugging/testing in both OpenAT environments.

e.g.

// give constants a shorter version
#define M_TEST		ADL_CMD_TYPE_TEST
#define M_READ		ADL_CMD_TYPE_READ
#define M_ACT		ADL_CMD_TYPE_ACT
#define M_PARA		ADL_CMD_TYPE_PARA

...

static const char * CMD_TEST		    = "AT###";

...

adl_atCmdSubscribe ( (ascii*)CMD_TEST,			MY_CmdHandler,			0x0030 |          M_READ | M_ACT | M_PARA );

Greets,
Heinz