Read serial data on FX30S

Hi guys,

I try to read serial data from UART1 using usp.
Somehow I have been able to get 1 single message of 5 bytes just after pushing the usp config. But I was expecting 30 Bytes… (frame fixed 30).
Afterwards, I tried to make an observation on the ressource and send data to the cloud but since then, I think my system is frozen.

here is my config :
“frame_timeout”: 0.5,
“framing”: {
“fixed”: 30
“string”: true,
“uart”: “UART1”

io/config/devs :
“conf”: [
“baud”: “2000000”,
“bits”: 8,
“flow”: “N”,
“own”: “usp”,
“pair”: “N”,
“routing”: “RP”,
“std”: “485”,
“stop”: “1”,
“term”: “OFF”,
“type”: “UART1”,
“wire”: “2”

Hi benoit.caby,

To avoid putting invalid values, could you try to configure via USP screen in the Service tab instead of pushing your configuration to usp resource?



I finally updated to 3.1 and get the USP service board.
The baudrate I want is not in the list. So I tried to modify it by hand. Are the baudrate constrained to some fixed values ?

Also I tried to make an observation on the USP but it bricked my FS30.
Now I’m unable to send any command to it. Is there no way to kill it remotely or trigger a safe reboot with all observations/tasks off ?

If it cannot be done remotely, is there a way to do it locally through USB ?

Hi benoit.caby,

You can only choose the baudrate that in the list.

To make your FX30 reachable, please follow:

  1. On octave cloud, please temporarily remove the observation and the value that you set on USP resource. Then reboot device manually.

  2. On module, connect to your PC by USB cable then ssh to port 22 with user “root” (no password required). So you can send command through ssh session.