Modbus and USP

On 3.0.0.pre03Jun2020 firmware (FX30S), I setup a Modbus on COM1 and USP on IOT0.
Modbus are running correctly.
After restart the FX30S, the Modbus doesn’t restart. I have to remove USP on IOT0 to restart the Modbus.

Additional condition : Counter ressource is setting.

Hello Romuald,

Thank you for this feedback.

Could you specify what works or not depending on the counter activation ?

I have tested the same setup (FW version, port configuration), with or without counter.
After reboot, the Modbus runs OK every time



Did you check the Modbus signal ? I detect the Modbus shutdown with scope.
Configuration : USP on RS232+ Energyia card

I applied my configuration “Config de base (Modbus/RS232)” version 3.
Then, I setup the Counter ressource at 5s (counter/enable=true and counter/period=5).

The signal is OK :

Then, I restart the FX30S with unpluging the power and the Modbus is stick low :


Hello Romuald,

in my case I don’t have a scope, but the Modbus slave I am connected to can be properly read & report values to the FX30S, even after restart with the Modbus + USP config enabled + counter enabled

So, I have to restore my FX30S ?
What is the procedure ?
What is your propositions ?


I see that you have the IO/serial configuration done at two places:

In io/config and in io/serial/config

Can you remove the part everything whichis in io/serial/config ?

There is no need to have it at both places together
(and if using io/serial/config, only the lower level of the JSON structure is needed no need for the devs & conf levels)


1 Like

Thank you Augustin, all is right.