Q26RD - SIM removed state, but it's not


#1

Modem : Q2686RD
Firmware : 7.44

I’ve seen a few reports on this forum about this kind of problem, but none related to the Q26RD. I’ve tried the suggested workaround anyway, but with no success.

I’ve developed an OpenAT application that performs a connection to a web server. Prior to that, I check the SIM state (adl_simGetState). Sometimes, I get « ADL_SIM_STATE_REMOVED » state and the connection is impossible. But the SIM is present !
Then, if I try “AT+CPIN?” The modem says “ERROR”.
I’ve checked the SIM_PRES PIN, which is set to 1 (Which means SIM present)

The behaviour happens only with a specific kind of SIM, with a specific operator (Swisscom, in Switzerland). I’m a bit confused, because the problem is new. My application has been running for 4 years with many different operators and SIM…

I have 2 questions:

  1. Does anyone know how I could workaround this problem? I whish I could reset the SIM (“AT+CFUN=0” then “AT+CFUN=1,0”). But the SIM is still seen has “Removed”. After an “AT+CFUN=1” the problem would be solved, but I can’t do this.

  2. I guess that it could be a kind of incompatibility between the modem and the SIM. I would like to guess the kind of specificity in the SIM is involved. Any idea?


#2

Hi,

Do you observe any pattern to have this problem happens? (e.g. in long run with that SIM? Do you use 32k mode?)
Can you test using latest FW (e.g. R7.46/R7.47)?

Any chance you can check with your FAE?
Thanks.
L


#3

I haven’t found any pattern. Not using 32k mode.
I have a specificity though : The modem is always switched off after each connection.
–> I turn the modem on, connect, exchange data then switch off.

I’ll try the lastest firmware, but anyway I hope there is another solution because updating the firmware on field would very very difficult, if not impossible.

I’m working with the FAE too, but still no result, yet …


#4

Hi,

It’s hard to guess without log…
Can you turn on “AT+CMEE=1;+WIND=32767;&W” before test and send AT+CPIN?+CEER after problem happened then share the AT log?

Guess your FAE can find some clue if you provided trace log, btw, test using latest FW r7.47 can help too.

Thanks.
L


#5

I’ve found a workaround: Now, I simply ignore the “SIM REMOVED” state and go on with the connection (wip_bearerOpen, etc). The connection succeed …