Problems on Boot


#1

Fastrack running 6.57 and Open AT 3.13
I have installed my own software on it (developed in the IDE)

It works fine, does all that it is supposed to.

However if it it powered on and off a few times it sometimes (it is not consistent at all) will not boot.

Instead of printing out all the startup information (ADL calls etc) to the terminal, it prints out garbage, ie 'þ€à øà ’

The little red light turns on the device stays on and it does not respond to AT commands. If I reset it it returns to normal.

Any ideas?

Cheers in advance.


#2

Hi Tim,

We’ve experienced a similar problem in the past. Our automated test equipment shuts down and reapplies the power supply automatically and the open AT app would not start approx 1 in every 100 restarts. (very random though)
This was improved substantially by ensuring a AT+CPOF was called before shut down of power, but the problem still occurs occasionally.

Never got to the bottom of this. I’d be interested if you learn any more.

Cheers,
Jedd


#3

I have a hunch that there are certain things that go on when a Wavecom unit starts that can interfere with an Open-AT application… :confused:

eg, see wavecom.com/modules/movie/sc … php?p=3332

Can anyone confirm this suspicion?

Are there any events before which certain operations should not be attempted?

Should one just make a delay before the application actually does anything at all?


#4

Hi

I have a similar problem but a little more often than 1 to 100.

I have even seen it when i made some experiments from hyperterminal, i then realized that it had changed the baudrate to 57600, and responded to AT commands whith that speed, but +CSQ answered 99,99 and a GPRS connection was not possibly.

An automated power off (i have a relay in the power) in 10 sec. did’nt solve it either . I apperently have to make a manual power off/on, to “get up” in a state that works.

Is any of you getting closer to solving the problem ??

/kbb


#5

What kind of “power off” are you doing that doesn’t work?

There are bugs in some modules/firmware where the module may start up at half the speed, and when you ask with +IPR? it will claim to be the original speed.
Ex: module configured for +IPR=115200
module starts up in half speed for some reason, +IPR? give +IPR: 115200

As far as I know, Wavecom have yet to admit that this problem exist at all, despite it being reported many times.


#6

Forgot to add…
Since Wavecom seems to completely ignore this problem (noticed a lot on Q2406B with 6.57 fw, but not on Q24PL001 also with 6.57 but with some changes to how power up is handled that is not the same as old modules), I’d like to find any way to programmatically detect this condition and force a restart when it happens.

As I said in previous post, querying IPR does not work, so does anyone know of any other way you can detect this?


#7

-> tobias

I’m not making aplikations IN the modem but im using the fasttrack as a external modem to my main processor. So the power off i’m doing is a fysical power off via a relay in the fasttrack’s power cord.

From the remote processor i can detect the faulty mode by trying different speeds to see which one the modem answers OK to a simple AT.

And i’m using 115200, so it’s possibly that it is the bug you are refering to.
I could live with a different communication speed, but my real problem is that when i does that, it responds to AT commands but GPRS connection is impossibly (as mentioned early’er).

I have off course tried a normal restart (+CFUN=1) but it dont brings the modem out of the faulty state.

/kbb


#8

The problem can occur with or without programs running.

For the units I have had problems with, running AT+CFUN=1 from program seems to work, but I have not tried in normal mode.

You could return the modem to your distributor and complain (and hope that Wavecom in the end will listen) or do a full restart.

I don’t think there is any way you can get normal behaviour from the modem when it starts up in the wrong speed, so a restart is needed.


#9

I haven’t got very far with this problem :frowning:
Although I can confirm that it happens whether or not a application is running and also with or without a sim card

This is the exact behavior I am experiencing
It seems to be able boot up normally (except with a different baud rate) but it has no signal strength and thus can’t send a text.

As a result the modem is dead in the water as far as my needs are concerned.

Tobias, I am working on a way of detecting this on the device (I have a hunch!). More on this when I get further…