Problem with miniRide


#1

Hello,

we are facing a problem with an eRide miniRide GPS module.
The sample application QueryApp is running OK on the C-GPS eval board, but it does not work with the miniRide module on our own hardware.
We have checked all the connections and the timings, and everything seems to be OK.
I’m Q2686 module, with C-GPS version 1.00.03.

However, our miniRide module has a strange product number written on it: GSZ03.
In the datasheet, and the product number on the picture is eMD1100Z. I have not find any information about GSZ03 so far, so this may cause the problem.

Any ideas?

Thank you,
Karoly


#2

Hi Zicostar,
The reference you can read is correct. It was a different name for the same thing. I believe you got this MiniRide module with your dev kit? This was the reference at that time, but nothing as changed apart from reference.
Conclusion: your module should be ok.
When you’re talking about your own hardware, is it that you have designed a prototype board with Q26 and MiniRide?


#3

Caribou, thanks for the reply.
Yes, we have a prototype board with minRide and Q2686.

You were right, the two miniRide modules with difference reference are the same.

Finally we solved the problem. It was a design mistake, namely the JTAG TRST (nr. 17) pin was not connected to the ground (but it was left unconnected).

Now it works fine.


#4

Hello

Maybe I found similar problem with MiniRide. I have problem with communication (I missed pin 17 Jtag - at this time it is also connected to GND). Communication Rx, Tx is good. But I cannot get any info from satellite. Maybe the RF part of eMD110Z is not still working. Eride core still answer only 10,20… The same example is working on Wavecom + C-GPS starter kit. All signals is verified with documentation which is available at this time.

Does anybody have some ideas ?

Regards

Radim


#5

Hello Ravo,

do you use active or passive antenna and do you design a 50 Ohm wire to connector ?


#6

Hi All,
I use active antenna but can see only one-two blue sattelite. As i read in documentation i have to connect it to RF_IN_2, but there is only one RF in mimiRide. Any ideas?


#7

Sorry for later answer.
Problem was in PCB - broken wire to VCC 3.0 for RF part ( it was under the part - so difficult to find.

Radim