Problem to run AT mode on Airprime Q2687


I have Airprime Q2687 modem that is running ADL software (I set it up long time ago) And now I need to stop this software and run AT commands.

In teraterm (tried speed 9600 and 115200) I typed: “+++” and “enter” but this does not stop program, no reaction.

I cannot remember what speed has been set up to COM1.

How can I force to stop program and change to AT mode on this modem?


if you can get an AT to return OK, then you can use AT+WOPEN=0 to stop the currently running application (and AT+WOPEN=1 to restart it again).

Have you got access to the USB port? You can try the same command over the USB connection … if the USB is enabled in the firmware (it is by default in latest versions (after 7.47?), but if you have an early 7.xx version the USB port on the module had to be enabled in software).

Worst case, remove it from your hardware, put it in a development board and then use DWLWin to erase the application - a bit drastic, but should work.

ciao, Dave

hi Dave,

Firmware I have is R7.51,
So I connect USB cable to Development Kit (Wavecom Q26), and I do not get anything in Device Manager, (Ports), do I need to install some driver?
Even I insert USB cabke to PC. System should detect new device, but nothing happen.

Worst case with DWLWin I already tried, it seems it cannot find right speed for COM port…
After setting it according to instruction:

  1.   set BOOT to ON
  2.   switch off power
  3.   press START (you received failure tries)
  4.   power up Development board

Got this massages:

Boot failure: unknown baseband or unexpected answer received
Cannot boot up the remote target: autodetection failed.