Position_Retrieval application not working


#1

This application never seems to work, I always get “GPS fix not obtained yet”. However, I can get the Query_App application to work by following the user guide instructions. Has anyone got this demo to work or should I just not bother with it.

Cheers, Misha


#2

Hi misha

you missing a step I guess.

have you enabled the active antena ? without it you wont get a fix.

try this

Disable keypad :AT+WHCNF=0,0

Set IO 8 as output :AT+WIOM=8,1,0

Set IO 8 to LOW level to enable the antena: AT+WIOW=8,0

let me know how you go with this.
this sample works for me.

have you tried aiding sample ?

cheers
Asiri


#3

Good idea, but executing the command “AT+WIOM=8,1,0” gives me a CME ERROR 3. What’s up?

BTW executing the command “AT+WIOM?” gives me an “OK” only


#4

I managed to enter the following commands OK, but still no fix:

AT+WHCNF=0,0
AT+WIOM=1,“GPIO8”,1,0
AT+WIOW=“GPIO8”,0


#5

hi
which app is this sample app or query app ?

i know aiding query app doesnt work.

other two demo apps works fine but i had set the active antena pin.


#6

The QueryApp application works fine, but the Position_Retreival application does not. I used the same commands for both applications.


#7

ok
that one takes while to get a fix, give it a good 10 minutes on target mode

cheers


#8

No good - it didn’t get a fix when I left it running overnight


#9

are you trying indoor ?

take it to open sky and give it a try.


#10

The GPS module IS working, another demo, QueryApp, works with the same commands. So I’m pretty sure the demo is a dud.


#11

it works

but I am not sure I changed the code.

It needs more time than other one because this doesnt have aiding.