Pi 4 + MC7304 GPS and LTE-data logging

What is the best/preferred way to collect and store continous/interval GPS and LTE-data to .csv, .txt or directly to sql-server?

Hi mariozz,

You can use Tera Term tool and register your MC7304 module on https://eu.airvantage.net/ server to collect and store continuous/interval GPS and LTE-data to .txt

Please help to mark “Solution” if your question is answered.

Thanks Donald!

Will mark as solved when i get the module registered and tested towards Tera Term.

Have another question as well, what is the method of retrieving data from the GPS unit directly from CLI?

Hi mariozz

Firstly, you need install the latest driver window for MC7304 https://source.sierrawireless.com/resources/airprime/software/airprime-em_mc-series-windows-drivers-qmi-build-latest-release/#sthash.ADsKgJd8.dpbs

Secondly, you use Sierra Wireless Snapdragon™ X7 LTE-A WWAN Modem port for AT command and Sierra Wireless Snapdragon™ X7 LTE-A NMEA Port for output NMEA GPS.

You can type these AT commands GNSS on Sierra Wireless Snapdragon™ X7 LTE-A WWAN Modem port to enable GPS.

AT!GPSNMEASENTENCE=<nmea type> ( (NMEA sentence types)
AT!GPSAUTOSTART=1 (1=Enabled GPS tracking session starts automatically when modem is reset)

Please refer to AirPrime EM73xx/MC73xx AT Command Reference for more details.

I have attached the screenshot as below for your reference.

1 Like

Hi again Donald and thank you for your reply!

To be noted i run the LTE-module through a shield on the PI (linux). PI is accessed through local wifi. I currently I am able to get the lte-data through shell script. But when requesting gnss related information (loc-start) i get this:
error: couldn’t create client for the “‘loc’” service: QMI protocol error (31): ‘InvalidServiceType’

any ideas if the GPS module is not available through linux (only airvantage) or have I missed something in the documentation?

Hi Mario,

Guess you are using qmicli and libqmi?
Per my understanding, MC7304 use “PDS” instead of “LOC”, please check if the tool support “PDS” service.
But referring to below, it seems “PDS” service is not implemented in qmicli/libqmi at the beginning, not sure the latest version.

But please note that this qmicli/libqmi tool is not maintained by Sierra, the official Linux tool is available:
Otherwise, you may also try AT command or NMEA port to capture the GPS info, it should be easy to integrate the logging feature via shell script or python also.

Hope it helps.