How do I get GPS data from MC7700 LTE?

I see in some places that the MC7700 LTE module “has integrated GPS capabilities.” How do I get access to this GPS information from the card? I’m working in a Linux environment.

I have the driver set up, and I can connect to the card over a serial connection. Does it come over one of the serial ports? If so, which, and what format is it in?

Hi,

Regarding GPS, connect to AT command port and enter GPS related AT commands to establish GPS session. GPS NMEA frames will be received on GPS/NMEA port of MC7710.

If NMEA frames are not seen by default, enable by using…….

$ sudo echo 1 > /sys/module/GobiSerial/parameters/nmea

Thanks.

Hello i want to use the gps to, i have a pf sense freebsd

[2.1-RC0][pf]/dev/usb(44): dmesg | grep ugen
ugen3.2: <Sierra Wireless, Incorporated> at usbus3

[2.1-RC0][pf]/dev/usb(45): usbconfig -u 3 -a 2 dump_device _desc
ugen3.2: <MC7710 Sierra Wireless, Incorporated> at usbus3, cfg=0 md=HOST spd=HIG H (480Mbps) pwr=ON

bLength = 0x0012
bDescriptorType = 0x0001
bcdUSB = 0x0200
bDeviceClass = 0x0000
bDeviceSubClass = 0x0000
bDeviceProtocol = 0x0000
bMaxPacketSize0 = 0x0040
idVendor = 0x1199
idProduct = 0x68a3
bcdDevice = 0x0006
iManufacturer = 0x0003 <Sierra Wireless, Incorporated>
iProduct = 0x0002
iSerialNumber = 0x0004 <358178040223176>
bNumConfigurations = 0x0001

But i dont know how i can use GPS from your module.
How i can use this nmea data strig as a serial signal?
I hope you can help me.

Thanks

Chris

Hello I also have a MC7710 module and I wish to be able to read the nmea sentences with minicom at first.

With the AT command I see that the module is on and have a position :

AT!GPSSTATUS?
Current time: 2014 06 19 3 13:33:46

2014 06 19 3 13:33:45 Last Fix Status = SUCCESS
2014 06 19 3 12:48:57 Fix Session Status = ACTIVE

TTFF (sec) = 5

OK

AT!GPSLOC?
Lat: 45 Deg 12 Min 30.36 Sec N (0x008097C7)
Lon: 5 Deg 47 Min 46.37 Sec E (0x00107CAD)
Time: 2014 06 19 3 13:34:51 (GPS)
LocUncAngle: 0.0 deg LocUncA: 3.0 m LocUncP: 3.0 m HEPE: 4.242 m
2D Fix
Altitude: 281 m LocUncVe: 3.0 m
Heading: 0.0 deg VelHoriz: 0.0 m/s VelVert: 0 m/s

OK

I have activated the NMEA sentences output :

AT!GPSNMEACONFIG?
Enabled: 1
Output Rate: 1

OK
AT!GPSNMEASENTENCE?
!GPSNMEASENTENCE: 0x113

OK

So everything seems to be well configurated but I don’t have any output on any of the different ttyUSB port when I monitor with minicom.
Do I miss something ?

Thanks.

Hi,

Did you set this

sudo echo 1 > /sys/module/GobiSerial/parameters/nmea

I don’t have GobiSerial folder in my linux but I think it’s because I work in Direct IP mode.
No matter what I succeed to have my ouput working thank to this forum and the user dl5162 !

the solution was to send this command :

to the nmea output port which should be the one before the AT command port.

Personally I find it totally scandalous that this command doesn’t appear in any of your documentations. I lost three days of work just searching for this, a simple one line command.
I think that it should appears in the Extended AT command documentation with the info that you NEED to do this in order to activate the nmea output.

Regards.
Tom

How to send this command echo $GPS_START >/dev/ttyUSBx
I have NMEA Port on USB3 but when I open USB3 I am not able to fire AT commands
nor this Echo command
Kindly guide How to enable NMEA Port and fire AT commands for GPS

Regards,
Sarang K.

you need not to fire the command in NMEA port…

Issue the command in the terminal…

Hi,
I am getting GPS data when I fire AT!GPSLOC? Command
but I am not sure How to get same data on NMEA Port,As per my understanding I need to open NMEA Port in one terminal and from other terminal I need to fire AT coomands…is that right.

But what AT coomand gives me continuous data on NMEA Port.Is it AT!GPSLOC only

Thanking You

Regards,
Sarang K.

hi,

Did you check !GPSNMEACONFIG command?

I am unable to get any NMEA output from my MC7710
—8<---- ati —8<----
Manufacturer: Sierra Wireless, Incorporated
Model: MC7710
Revision: SWI9200X_03.05.19.04ap r5475 carmd-en-10527 2012/09/17 17:57:14

I’m on Ubuntu 14.04
Modem is in Direct IP Mode it shows 5 ttyUSB devices when I connect it.
I’m assuming these to be:
ttyUSB0 => DM
ttyUSB1 => CNS
ttyUSB2 => NMEA
ttyUSB3 => AT
ttyUSB4 => DATA
I can establish data connections using ttyUSB3 and ttyUSB4.
I cannot however see any GPS NMEA output on ttyUSB2.
I’m using minicom -D /dev/ttyUSB2 -o @ 115200
I don’t have /sys/module/GobiSerial/parameters/nmea
I do have …/sierra/parameters/nmea which was N. I’ve set it to 1 and it now shows as Y
I have also tried echo $GPS_START > /dev/ttyUSB2 (and others out of frustration)

I still always get ErrCode 17 when I try and do anything…
at!GPSFIX=1,60,500
ErrCode = 17

Any help would be greatly appreciated.

Addendum:
I also tried to use AT!CUSTOM as referenced in the extended AT command set - but it always returns an error when I try and set a value:
AT!CUSTOM?
!CUSTOM:
PUKPRMPT 0x01
MEPCODE 0x01
ISVOICEN 0x02
PRLREGION 0x01
PCSCDISABLE 0x03
GPSENABLE 0x01
GPSLPM 0x01
OK
AT!CUSTOM=“GPSENABLE”,1
ERROR

Update - I worked it out eventually.
I didn’t realise that the AT!CUSTOM command was password protected.

Eventually I was able to enable the GPS NMEA output with :

AT!ENTERCND=“A710”
AT!CUSTOM=“GPSENABLE”,0x04 (Using table 3.2 Modem status…)
AT!RESET (needed before it started issuing NMEA sentences

Now it outputs NMEA sentences on /dev/ttyUSB2 as I was hoping.