MC7710 on linux kernel 3.2 and gps


#1

Hi,

i have tried to use our first direct ip modem (MC7710) on our embedded device running kernel 3.2.
The modem (building up a connection to the provider) works fine but i cannot get any gps output.

Our previous card was the MC8790 which gave us severel serial ports (ttyUSB0 to ttyUSB6) i think. The MC7710
(detected as 1199:68a3 on the usb bus) gives us several usb ports too (ttyUSB0 to ttyUSB4) but no port allows us to receive gps data like the MC8790.

On a Windows 7 PC i can use this card like the MC8790:

  1. Open the AT-Command-Port in a terminal and enter the at!gpstrack command
  2. Open the NMEA-Port in a terminal and i receive the gps data

And yes, gps is enabled i think because the at!gpstrack command sends no error code, only OK
( I already enabled gps by entering the at!entercnd=“XXXX” and at!custom=“GPSENABLE”,1 command…)

Has someone an idea why this isn’t working?

I tried this card also in qmi mode without success (changed the pid to 68a2).

The driver version is 1.7.40. (sierra.c).

Both modules (sierra.ko and sierra_net.ko) are inserted.

Thanks in advance and best regards

Tobias


#2

BTW: i have access to the extranet and the firmware, docs etc. but where can i find the linux sdk of the mc7710?


#3

You have to write the magic $GPS_START string to the NMEA port to start streaming NMEA commands, in QMI mode at least.

Using the MC7710 in QMI mode with GPS enabled:

bjorn@nemi:~$ ls -ld /sys/bus/usb/devices/2-4\:*/tty*
drwxr-xr-x 4 root root 0 Jun  2 11:33 /sys/bus/usb/devices/2-4:1.0/ttyUSB0
drwxr-xr-x 4 root root 0 Jun  2 11:33 /sys/bus/usb/devices/2-4:1.2/ttyUSB1
drwxr-xr-x 4 root root 0 Jun  2 11:33 /sys/bus/usb/devices/2-4:1.3/ttyUSB2

USB interface #0 is Qualcomm DM, interface #2 is NMEA, interface #3 is AT command. So in my case, the NMEA port is ttyUSB1. Set it to raw mode, start streaming and add it to gpsd:

stty raw -F /dev/ttyUSB1
echo \$GPS_START >/dev/ttyUSB1
gpsdctl add /dev/ttyUSB1

ref http://www.thinkwiki.org/wiki/Qualcomm_Gobi_2000

This is a generic Qualcomm thing, so I’m not sure it works in DirectIP mode. Note that there is a “nmea” option for the “sierra” driver, which will make it send a SWI specific control message when attaching. That could make a difference in DirectIP mode. I haven’t tested it.

Bjørn


#4

Thanks Bjørn, i will take a stab at it on monday and thanks fpr the Gobi link.
That’s very interesting.


#5

For your information:

Using the MC7710 in direct IP mode on linux kernel 3.2 (driver 1.7.40):

  • 5 serial ports are attached: ttyUSB0 - ttyUSB5

ttyUSB3 -> AT command port
ttyUSB2 -> NMEA port

To get gps data through the NMEA port i had to send $GPS_START to it after sending the AT!GPSTRACK command to the AT command port.

Thanks to Bjørn for his hints.

Tobias