MC7304 how to retrieve gps coordinates? what next?


#1

Hello,

First and foremost, it is my goal to retrieve gps coordinates using a daemo via my mc7304 modem connected to an external gps antenna.
I have to work with centOs 32bit. According to the Linux QMI SDK Application Developers Guide Rev1.26_1 I should be at point 3.3.9.
I find devices ttyUSB0-2 and gcqmi0-gcqmi1 in /dev and via ifconfig I see that the device has an ip adress.
qmicli and qmi-network is installed.
I was able to dispatch AT commands via serial to ttyUSB2, but unfortunately i cannot use the device, as pppd blocks the interface. At the test I wasn’t able to get a GPS location fix.
Is it possible to retrieve gps coordinates via qmi-cli?
If not, where do I go from here? Do I need to install the SDK? I cannot make / build on the hardware at hand. If necessary I could work on a development machine.
Also I would prefer to use Python for ongoing developments.

I would appreciate any help! Thanks


#2

Have you tried CMUX over AT command port so that you can have one more port for AT command?

About the QMI SDK, I saw there is a sample application PDS_Services and LOC_Service which might be useful to you.

Another option is that you can use AT!SCACT to establish data connection instead of using pppd over AT command port.
In this case, you will have AT command for GPS function.


#3

I did not try CMUX. How do I use it?
I saw the samples too, but I cannot make the SDK.
Unfortunately it is not an option to give up on pppd.


#4

If you are using linux pc to test, you don’t need to compile the sdk as there is already pre-compiled binary in the build folder.


#5

In the meantime I found that out too. I tried to execute pdsserviceshosti686 with the path to the i686 slqssdk, but it failed with SWI API SDK launch failed: Permission denied.
I tried sudo su and rw on / but it failed with the same error message.
Do you know why? My next step would be to try to recompile the pdsserviceshosti686 binary, assuming that some libraries are missing.
If I needed to recompile the sdk, where would I get the source?


#6

try “sudo ./pdsserviceshosti686”.
I think you need to contact the distributor for getting the source.


#7

Check if you have execute permission set for pdsserviceshosti686