Peer-to-peer? using pairs of Fastrack Supreme modems


#1

Hi,
We have bought a dozen Fastrack Supreme modems. We want to poll outlying slave equipment from a central master Linux box.

We are having difficulty dialing and logging onto the outlying equipment. We’ve tried (1) using a terminal program (minicom) to talk to the modem – “AT”, “ATDTnnnn”, etc, work just fine. And (2) using pppd to dial a landline works just fine, but authentication to an outlying box to a second Fastrack Supreme just doesn’t work.

So far, we’ve tried variations on this: this is /etc/ppp/peers/wavecom_00:

/dev/ttyS0
9600
# The following are from Fastrack/GPRS UserGuide.pdf:
nodetach
debug
kdebug 7
crtscts
name F075PPP
connect "/usr/sbin/chat -vs ECHO OFF AT\r OK ATE0V1\r OK ATDT0458783786 CONNECT"
novj
nomagic
asyncmap 0
defaultroute
usepeerdns

The command then used is

pppd file /etc/ppp/peers/wavecom_00

The /var/log/messages file only shows:

Oct 19 16:35:11 lw-scada-ppp1 pppd[5747]: pppd 2.4.4 started by ppp, uid 0
Oct 19 16:35:12 lw-scada-ppp1 chat[5749]: expect (AT^M)
Oct 19 16:35:57 lw-scada-ppp1 chat[5749]: alarm
Oct 19 16:35:57 lw-scada-ppp1 chat[5749]: Failed
Oct 19 16:35:57 lw-scada-ppp1 pppd[5747]: Connect script failed
Oct 19 16:35:58 lw-scada-ppp1 pppd[5747]: Exit.

Any suggestions, either actual set-up, or links to useful documentation, would be warmly welcomed.

Thanks in advance.
Alf Lacis