PC cannot PPP to Supreme 20 for GPRS connection


#1

Guys

I couldn’t PPP to my supreme 20 from PC for GPRS connection with AT commands. :blush:

My supreme 20 is fresh bought from the shop without any prior settings or loading.

Is it some setting wrong with UART1 or 2? Or something?

Here are the full details of my AT commands and PPP setting:
http://www.geocities.com/bambinorama/tb1.pdf

I followed these steps:
http://www.rfsolutions.co.uk/acatalog/AT_cmd-GPRS_User_Guide.pdf

Thanks.


#2

I still don’t see why you need a GPRS modem at the PC?

See: viewtopic.php?f=74&t=1952&p=7262#p7262
and: viewtopic.php?f=53&t=1917&p=7213#p7213

Doesn’t the PC have an internet connection?


#3

No, that’s not the full details:

You haven’t showed that you’ve correctly followed the steps in section 6a Defining a remote dial-up connection on PC

The error you receive comes from Windows dial-up networking:
[attachment=1]supreme_error_692.gif[/attachment]
What does it tell you if you click the ‘More Info’ button?

Go to Control Panel -> Modems, and look at the properties that you’ve set up for the modem;
Go to the ‘Diagnostics’ tab:
[attachment=0]modem_properties_diagnostics.gif[/attachment]
Note the ‘Logging’ section at the bottom - this allows you to view all the commands & responses exchanged between the PC and the modem; eg,

So you can see exactly what’s happening and, hopefully, where it’s going wrong…

But, again: doesn’t the PC already have an internet connection? Why do you (think you) need to use a GPRS modem?


#4

I was trying to familiarize myself with connecting to GPRS with AT commands before attempting the heavy work; coding. :blush:

Many thanks for the diagnostic hint.

In the diagnostic:

01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\tapisrv.dll, Version 5.1.2600   
01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\unimdm.tsp, Version 5.1.2600   
01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\unimdmat.dll, Version 5.1.2600   
01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\uniplat.dll, Version 5.1.2600   
01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\drivers\modem.sys, Version 5.1.2600   
01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\modemui.dll, Version 5.1.2600   
01-21-2008 10:54:12.619 - File: C:\WINDOWS\system32\mdminst.dll, Version 5.1.2600   
01-21-2008 10:54:12.619 - Modem type: Standard 19200 bps Modem
01-21-2008 10:54:12.619 - Modem inf path: mdmgen.inf
01-21-2008 10:54:12.619 - Modem inf section: Gen192
01-21-2008 10:54:12.619 - Matching hardware ID: mdmgen192
01-21-2008 10:54:12.635 - 19200,8,N,1, ctsfl=1, rtsctl=2
01-21-2008 10:54:12.635 - Initializing modem.
01-21-2008 10:54:12.635 - DSR is low while initializing the modem. Verify modem is turned on.
01-21-2008 10:54:12.635 - Send: AT<cr>
01-21-2008 10:54:14.635 - Timed out waiting for response from modem
01-21-2008 10:54:14.635 - The modem failed to respond to the initialization command, Retrying one more time
01-21-2008 10:54:14.635 - 19200,8,N,1, ctsfl=1, rtsctl=2
01-21-2008 10:54:14.635 - DSR is low while initializing the modem. Verify modem is turned on.
01-21-2008 10:54:14.651 - Send: AT<cr>
01-21-2008 10:54:16.651 - Timed out waiting for response from modem
01-21-2008 10:54:16.651 - The modem failed to respond to the initialization command, Retrying one more time
01-21-2008 10:54:16.651 - 19200,8,N,1, ctsfl=1, rtsctl=2
01-21-2008 10:54:16.651 - DSR is low while initializing the modem. Verify modem is turned on.
01-21-2008 10:54:16.666 - Send: AT<cr>
01-21-2008 10:54:18.666 - Timed out waiting for response from modem
01-21-2008 10:54:18.666 - Session Statistics:
01-21-2008 10:54:18.666 -                Reads : 0 bytes
01-21-2008 10:54:18.666 -                Writes: 9 bytes

It seems like the PC is trying to communicate with the modem with 19200 instead of 115200.

But…The modem is set to max speed 115200 already?

Did a bit of digging after reading diagnostics…

The modem is still set at 19200! :open_mouth:
I personally think M$ windows sucks. :blush:

Thanks again for the pointer, guys.


#5

Not a bad idea in general.

But note that you won’t be using AT commands in your Open-AT application - you will use API calls instead.

And, again, there is no point in having a GPRS modem at the PC end unless the PC has no other internet connection!

Well, certainly as far as setting up modem connections like this, yes - it does!

I think there are at least three different places where you need to set the baud rate when creating connection like this - presumably, you must’ve missed (at least) one… :frowning:

I’ll have to check…


#6

Try:

  1. Device Manager: under ‘Ports (COM & LPT)’ - for the COM port you use;
  2. Device Manager: under ‘Modems’ - for the modem you created;
  3. Network Connections - for the connection you created.

#7

Very helpful places, many thanks. :stuck_out_tongue: