Open a listening TCP Port & route packets to RS232

you can see if it can ping each other through USB

From terminal I can ping

then you can try this:

I’m not sure what you’re after here, but the linux PC has got an IP address from the modem (it wouldn’t ping otherwise). ipconfig reports it as getting

you can try with the nc tool first instead of legato app:

  1. Disable firewall by
    iptables -I INPUT -j ACCEPT

  2. transfer this nc file to module 's /tmp folder:

nc (756.4 KB)

  1. module side:
    chmod 777 /tmp/nc
    /tmp/nc -l -p 1234

  2. PC side:
    owner@owner-ThinkPad-X220:~$ netcat 1234

This can ensure the TCP server is working fine via USB ECM interface.

Do I run the iptables -I INPUT -j ACCEPT line on the modem or on the pc?
The modem does not recognize the instruction & the PC says there is no permissions

I don’t see problem:

owner@owner-ThinkPad-X220:~/Desktop/MC7455_FW$ sudo ifconfig usb0
[sudo] password for owner: 
owner@owner-ThinkPad-X220:~/Desktop/MC7455_FW$ ssh root@
root@fx30:~# iptables -I INPUT -j ACCEPT
root@fx30:~# cm info
Device:                        WP7702
IMEI:                          352653090002791
IMEISV:                        6
FSN:                           VU735370340201
Firmware Version:              SWI9X06Y_02.36.06.00 63d944 jenkins 2020/12/10 19:12:28
Bootloader Version:            SWI9X06Y_02.36.06.00 63d944 jenkins 2020/12/10 19:12:28
MCU Version:                   002.015
PRI Part Number (PN):          9907365
PRI Revision:                  001.001 
Carrier PRI Name:              GENERIC
Carrier PRI Revision:          001.071_001
SKU:                           1103530
Last Reset Cause:              Power Down
Resets Count:                  Expected: 411	Unexpected: 28

So I restarted the pc & now in terminal it recognises the sudo ifconfig usb0 instruction but wont accept my password. When I installed Acrolinux I set my log in password & checked the box that said to use it for admin also. The password works when I log in, but not in terminal!?!
I have tried restarting & even a shut down/power on cycle but no further change

you might reinstall Ubuntu 18 in VMWARE

I’m not using VMWare or any other virtualisation software. I have installed Acrolinux onto a spare HDD - swapped it out for my win7 drive so that I can revert easily
I’ll try re-installing it tomorrow as I am running out of work time today

Good morning.
The reinstall resolved the password issue, but said there was no port found for usb0
I have now installed Ubuntu 18.04 & it is telling me that ifconfig command not found

I have installed net-tools & now it has ifconfig, but is giving the same issue as Acrolinux - no usb0 device Is there a way to check which usb* device it is actually connected as?

You can check dmesg for kernel log

I get the following re the FX30S:
[ 1.231299] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1.231305] usb 2-1.2: Product: Sierra Wireless FX30(WP7702)
[ 1.231321] usb 2-1.2: Manufacturer: Sierra Wireless, Incorporated
[ 1.231326] usb 2-1.2: SerialNumber: VU01918551041021
[ 1.236958] tsc: Refined TSC clocksource calibration: 2494.333 MHz
[ 1.236996] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x23f45085418, max_idle_ns: 440795285711 ns
[ 1.237063] clocksource: Switched to clocksource tsc
[ 1.307004] usb 2-1.4: new low-speed USB device number 4 using ehci-pci
[ 1.408494] ata4: SATA link down (SStatus 0 SControl 300)
[ 1.410338] usb 2-1.4: New USB device found, idVendor=09da, idProduct=c10a, bcdDevice=10.32

it should be something like this:

[2739973.563672] usb 1-1.2: Product: Sierra Wireless WP7702
[2739973.563677] usb 1-1.2: Manufacturer: Sierra Wireless, Incorporated
[2739973.563682] usb 1-1.2: SerialNumber: VU73537034020105
[2739973.565850] qcserial 1-1.2:1.0: Qualcomm USB modem converter detected
[2739973.566104] usb 1-1.2: Qualcomm USB modem converter now attached to ttyUSB0
[2739973.566793] qcserial 1-1.2:1.2: Qualcomm USB modem converter detected
[2739973.567055] usb 1-1.2: Qualcomm USB modem converter now attached to ttyUSB1
[2739973.568040] qcserial 1-1.2:1.3: Qualcomm USB modem converter detected
[2739973.568297] usb 1-1.2: Qualcomm USB modem converter now attached to ttyUSB2
[2739973.571875] qmi_wwan 1-1.2:1.8: cdc-wdm0: USB WDM device
[2739973.573135] qmi_wwan 1-1.2:1.8 wwan0: register 'qmi_wwan' at usb-0000:00:1a.0-1.2, WWAN/QMI device, de:7f:e3:5f:6b:60
[2739973.578993] cdc_ether 1-1.2:1.19 usb0: register 'cdc_ether' at usb-0000:00:1a.0-1.2, CDC Ethernet Device, 96:7d:2d:53:cb:94

You need to check

Do I need a USB driver? I have nothing along the lines of Qualcomm for anything

you can install the MBPL USB driver:

I’m still having issues. I got help from a guy here who really knows linux inside & out (mostly terminal though) & he was as lost as I am. I never got the nc thing working on the USB at all. As this is not the desired connection method I gave up on it.
I have tried the leaf plugin to VS & had a whole bunch of issues (thought I had bricked the modem at one point) so have gone back to developer studio (windows version). I can load the UART_TCP_Server & it appears to start up, but when I run the app runProc line I do not get a prompt back. When I ctrl-c to get it back Developer Studio says it is no longer running. If I re-power the modem app status says it is not running. If I run the app runProc line I lose the prompt again & there is no coms through.
I have had to create my own Project name (FX30S_LTE) to open the files & compile as I could not import the files so have substituted UART_TCP_Server for this in the app runProc line.
I have also changed the port number to 6785 as this is the port I want to use.
Neither of these should cause any problems as far as I can see
I have tried Putty, WinSCP & Developer Studio Terminals as well as linux terminal & they all behave the same way

I am currently running the latest Ubuntu as I was having issues with 18. This is on another machine to my windows one for if I need to use linux for anything

Another weird thing I have noticed is that after setting AT!MAPUART=17,1 & re-powering the modem, I send AT!MAPUART? & it responds with 17,0