Not connecting


#1

Hello all again.

I have a little new problem. My modem is working correctly (it's a m1306b). It gets it's own IP, starts the bearer, etc, but when i try to access it using telnet (telnet x.x.x.x), i get this error: "Connecting to x.x.x.x...Could not open connection to the host, on port 23: Connection failed".

I know port 23 is telnet reserved port. I have tried to reach the modem with several computers, but all of them give me the same error. Can someone give me a hand on this? Thank you in advance :slight_smile:.


#2

Does the modem run a telnet daemon?
If you don’t know, then most certainly not.

And on the computer that is using the modem, you might want to check if you can set up a telnet daemon if that is what you are trying to do.


#3

Hi, thanks for the answer. I’m afraid I have no idea of what the problem is, could you explain that a little? I have very few experience with this kind of programming…


#4

Are you sure that your modem gets a Public IP address; ie one that is actually accessible from outside your GPRS network :question:

See: wavecom.com/modules/movie/sc … c++address

If you want to Telnet to your modem, then you must have something running in your modem to handle the Telnet protocol.

It’s just like if you were doing a dialup data call, and wanted to transfer a file using XMODEM - you would need an XMOMDEM handler running on your modem.