No Target Management devices with DS 3.4


I am trying to develop a program for FX100 with Developer Studio 3.4 and I find no devices show in the Target Management device list. Clicking on “Refresh Aavailable ports” does not help. Status Tab says “No Communication port available” even though some ports are available.

I was working OK with 3.3 until I upgraded to 3.4 and then this problem happened.
I have tried on a second computer starting with 3.1 and upgrading to 3.4 and the same problem happened.

Is this a known problem and is there a solution to it?

Is there a way to get back to 3.3 because when I try through “Install New software” an attempt to install “IDE for Open AT Framework 3.3” gets overridden to 3.4.

Best Regards


I’m assuming you’re using windows as your operating system…

You can reinstall ds3.3 by setting the install directory manually when running the setup installer. Just make sure you don’t set the install directory to the default.

DS is based on Eclipse, and you can keep as many versions as you want as long as you install each version into different directories. Although, this may no longer be the case with ds3.4 for legato as it uses additional tools such as boot2docker and virtual box to provide linux based compilation on windows.

Ciao, Dave

Hi Dave,

Yes i am using Windows 7 32 Bit.

I don’t have the installer for DS 3.3 for FX100 so i can’t install it in a separate directory.

Installer for 3.1 for FX100 is available at: … 698_fx100/

3.4 is now the recommended update in this Developer studio 3.1 but it gives me the problem i have mentioned.

Best Regards

Hi Tom,

Sigh. This is one of the reasons I’ve been pushing for full off-line installer packages, rather than only the lite installer that does an on-line install.

I’ve just done the following:

  1. Install DS3.0 (from the site you linked to). Make sure that you DON’T install the latest version from the Web (i.e. install this package), and that you install DS into a clean directory (say c:\DS3.3)
  2. Once the package has installed, Start DS, select a workspace (C:\DS3.3\workspace), and close the welcome screen
  3. Select Help->Install new software
  4. In the ‘Work With’ dropdown at teh very top of the ‘Available Software’ window, select as the site to get updates from. This will fill in the box underneath with a list of available software (i.e. Developer Studio IDE etc)
  5. There are a group of checkboxes underneath the list that’s just appeared. Uncheck the box “Show only the latest versions of available software”
  6. go back up to the list of software that’s available and expand “Developer Studio: IDE”. Scroll down the list until you see “IDE for Open AT Application Framework”, with the version Check this version of software.
  7. Expand Miscellaneous
  8. Select the version 3.3.0 versions of * Build System for OpenAT Applications
  • CDT miscelaneous extensions
  • Common bundles for Target Management
  • Common utilities
  • EBS Target Binding
  • External Tools Manager
  • Generic Build System for Sierra Wireless applications
  • Minimum Product-required bundles
  • Notification Center
  • Remote Devices access management
  • Software Packages Manager
  • Software Package Manager for OpenAT Application Framework
  • Target Management for OpenAT devices
  • Technical Report Management for Developer Studio
  1. Click ‘Next’.
  2. You might get a warning that the installation cannot be completed as requested. Select the option “Update my installation to be compatible with the items being installed”
  3. Click Next, and accept the licence agreements
  4. Click Finish, and wait… for the software updates to download and install
  5. Restart DS when requested

Note that you might get a warning when re-opening DS that the workspace was written with an older product and will be updated. Think about this, or create a new workspace to play in.

Also note that the version info in the DS splash screen is now 3.3.0.xxxx.

I think this will get you back to working with DS 3.3.0.

Don’t upgrade this version!

Let me know how you get on.

ciao, Dave

Thanks Dave.

I will give it a go tomorrow.
Today I have been managing using DS3.4 to code/build new FX100 firmware and the Target Management Tab from a separate DS3.1 install to USB download/debug my ADL firmware on FX100.


Hi Dave,

Your process worked to install DS 3.3. Thanks for your help.

Best Regards