Need old EM7455 Firmware

I need firmware SWI9X30C_02.20.03.22 (Verizon preferred by I’ll take generic) for a EM 7455.

We have 4 Lenovo X1 Tablets (Gen 2 mostly) with EM 7455 broadband card and a Verizon private APN assigned to them. We needed them to turn on and connect to Verizon and have the user login. First tablet worked fine. Second however didn’t. We also noticed that that the tablet was NOT joined to our domain it worked fine OR if after you turned on the computer, booted it to login and rebooted you could also get it to connect. The error upon cold start was “Cannot Find APN”, even though the APN was set and provisioned. We also saw Windows creating multiple profiles for the same device and connection. Upon reviewing firmware versions I found that the only tablet that doesn’t work while joined to a domain is running firmware SWI9X30C_02.24.05.06. To confirm this I then upgraded another working tablet to SWI9X30C_02.24.05.06 and promptly broke it. It does the same thing the other laptop running SWI9X30C_02.24.05.06 does and won’t connect on cold start. So now I desperately need the old firmware to full confirm my theory…and to report this to someone.

A very nice person sent me the firmware. However I’m having an issue applying it…Lenovo drives keeps updating it back to newest. I’m reformatting the system and will downgrade and see what happens

Look for a Configuration.ini file along with the driver install application. It describes the Carrier PRI/Firmware Image mapping. I believe it might be installed in C:\DRIVERS\WIN\WWANSREM7455\Configuration.ini during setup. Not sure about this, as I am not using Windows myself. But look around and you’ll find it.

The file documents a number of possibly interesting driver install options, BTW.

Were you able to downgrade it at all, even temporarily, before the drivers updated it back to the newest? I mean, does it downgrade at all or does the “upgrader” just say “no need to upgrade, the module already has a newer firmware”?

If the downgrade was possible, I would be very happy & grateful if I also met that kind of a very nice person who could send me the older firmware. :smiley:

So I have a similar problem with 2 pcs of MC7455 but AFAIK they use the same firmware as EM7455. My application is freeBSD, or actually pfSense firewall package built on top of freeBSD. It worked nice, but I was curious to see if the upgrade to the newest SWI9X30C_02.24.05.06 brought any new functionality. At first I thought it worked ok so I also upgraded the other module too. Thereafter I met a serious problem and now I have two useless (from my point of view, non-functional) modules.

I had copypasted the result of ATI command before the upgrade, this is what I had before and it worked, so it’s also what I’m now looking for:
Revision: SWI9X30C_02.20.03.00 r6691 CARMD-EV-FRMWR2 2016/06/30 10:54:05

It’s essential the firmware would be a generic one, not any operator-spesific version.
Sierra’s website obviously offers only the newest one. Or is it available somewhere? I did find some legacy drivers etc but not the firmware.

@dubinl do you still have a copy of the firmware? I have an application where that seems to be the only firmware that works and I’m having a hard time locating it.