Modems resetting and eventually stops responding

We have Wavecom Supreme modems crashing at random intervals between 15 minutes and 40 minutes. In most cases the modems will recover and continue service, but every once in a while, it will stop responding completely. Recycling the power to the modem always solves the issue. These modems are quite busy and may send/receive up to a thousand SMSes per hour.

Some background info: We have 4 Wavecom Fastrack Supreme 20 modems connected to a single server. Two modems are used for sending SMS’es and two modems for receiving SMS’es. The receiving modems are polled constantly (user definable interval) while the sending modems are only communicated with when an SMS is sent. The crashes are always on the receiving modems. We are using the USB connection (expansion card), but serial (RS232) seems to have the same issue. (Unfortunately, the problem manifests in a different way with RS232, so this is not conclusive).

We have extensive logs of all transactions to the modem, so I am able to give you a pretty clear picture of what is happening.

  1. The problem happens during times of high SMS traffic
  2. Windows will report to our software that the USB connection has failed.
    2a) First, a USB request will fail after a random period with “I/O operation has been aborted…”
    2b) Next, all subsequent requests will return immediately with “Device attached to the system is not functioning”
  3. Most of the time, the failure only persists for (a random period) of a few seconds.
  4. Once in a while, it will fail to recover and only a power cycle will bring it back again.
  5. Sometimes, it will fail again a second or two later. This has happened as much as 5 times in a row.
  6. Time between failures are random, but it seems no shorter than about 13 minutes and at least once an hour.
  7. The problem is very repeatable and failure always happens with the same error codes.

It is clear that the USB connection fails, which indicates that the modem CPU may be resetting. It will also seem that these (auto) resets are not always complete (or successful), because we have observed a number of times that the modem responded again after a soft reset, but it fails to connect to the GSM network. Again, a hard power cycle will solve this.

Things that we tried (with no success):

  1. Swapped modems around and even got two new modems
  2. Tried different (higher quality) USB cables
  3. Tried a combination of USB ports on the motherboard and on a USB addon card
  4. Added a whasher to the antenna connector to improve the ground reference (Wavecom document ref: WA_DEV_Fastrk_CRN_002)
  5. Moved antennas further apart and as far as possible away from the USB cables

We are pretty confident that the issue is not with our software as the software had been in use for more than 7 years. I can provide more information (logs, etc.) if required.

Modem info is:
at+whwv => Hardware Version 4.22
at+cgmr => R71a01gg.FSU005 2076692 052808 20:08

Have you changed the modem’s firmware recenly?
Is there an application in your modem or you are commanding by AT?

  1. We did not change the firmware at all. It is still as supplied to us.
  2. We are only using AT commands sent via USB connection.

That is worst than I thought… Have you tried changing the SIM?

Yes, we have tried swopping SIMs around. (We are currently using 64KB SIMs)

i’ve noticed this problem in my Q2686 as well, after a few crashes (i2c comm problems) the modem isn’t able to connect to the network (at+creg? responce never reaches +creg: 0,1)

Hi there,

we have some issues with our wavecom modems as they seemed to be frozen sometimes.
We actived reset function every 4 hours with AT+WRST=1,“004:00”; it seems it solves some issues sometimes. I am keen to rest the modem every hours but have not tested so far. Have you tried this?



We have also tried the reset function, but on 3 minute intervals. This is a very bad idea if you are using a USB connection. We found that regular resetting would eventually cause Windows to disable the USB ports. The only way to get the USB working again would be to restart the PC. If you are using RS232 then this may not be a problem.



Wouldn’t it be better if you raise the issue with Wavecom …?? I feel the problem can be better handled by the Support people there… Just ask your distributor for that…

n regarding the USB resetting , please see this topic…

hope it helps… :slight_smile:

That is an extremely bad idea!

If the network sees a device restarting that frequently, it is likely to assume that it is faulty, and “blacklist” it…

Alfega, did you get a response / solution from wavecom?

I got exactly the same problem (modem crash under high traffic situations)