Modem not responding after wipcreate


#1

hello, I have a wismo 228 modem in an embedded application meant to be connected as a client. It works well if the server I am connecting to is up. If that
happens, all goes well, and I am able to exchange data. But, If the server is down for some reason, the command
AT+WIPCREATE=2,1,“1.2.3.4”,4000…this is just an example, ip address being 1.2.3.4 through port 4000…
will never return an answer, not even with AT+CMEE=1 enabled before. Trying a escape sequence +++ doesn’t work either. The only way I am capable of recovering the modem is
with a power off.

I just received a new firmware from my provider: L10_00gg.WISMO228 031109. This solved an issue I was having with WIP commands not responding.

I hope anyone can help me, thanks.


#2

I have the same problem. How can it be solved?

I.e. turns out that the modem WISMO 228 loses connection after a prolonged absence of exchange.


#3

you can use this command AT+WIPBR=3,6,15,check this module’s IP.and then WIPCREAT .

or you can use this Firmware: L22.