Modem HL8548 new firmware ( connection problems

We have HL8548 modems with old firmware ( and with new (
We are connecting modems to converters. The converters has connection to the network only using modems with the old firmware ( version. When we are using modems with the new firmware ( version, converters don’t have connection with network, the modems configuration is the same.
Where could be a problem?
Maybe the connection initiation commands are different between versions ( and

Thank you.

Did you capture AT command log to compare?

No, how can I do that?

are you using MCU as the host ? OR you are just using Windows or linux platform to send AT command?

I’m using Windows platform to send AT command.

do you mean you do dial up from Windows in order to establish data connection?
Are you using USB or UART for AT command communication?

For AT commands, from the Windows, I’m using RS232 with converter to USB.

then you can use some spy tool (e.g. accessport 137) to see what AT command has been sent through this RS232 port when doing dial up from Windows platform

I tried this spy tool, and I get following result
with not working modem:

and with working modem:

Also converter manufacturers sent me a log, what commands converter send to the modem to make connection.








ATDT * 99 ***1#

+CREG: 5 means it is in roaming network…

Does the NOK one register the same +COPS?

I think the roaming network is written, because the modem is connecting to the operator’s closed network.
I have only one sim card, and I use it for both modems. When not working modem booting, it do not print +COPS line.

then if you use tera term to access the AT command port on NOK module, what is the return of AT+COPS?

Both modems prints
+COPS: 0,0,“Telia LT”,2

then that means both modems can register network, right?
so the problem is coming from PPP dial up, right?

have you installed wireshark log to investigate the PPP log over the modem port for dial up?

To the network can not registered only one modem, with new firmware version (, modem with old firmware ( is working fine. Both modems has the same configuration.
No I don’t check with wireshark, I try to look.

I try to connect via PPP. Modem does not connect to the network and wireshark does not capture anything.

Can you try if linux platform can see anything in wireshark?

Or you need to do analysis on raw ppp communication.

Btw why don’t you use the old fw?
Have you tried the fw between these two fw?

Unfortunately I don’t have Linux.
I think, this is new version off HL8548 modem, and them the last downgradable version is When I try to downgrade to version, I get an error.
Old modems are old HL8548 version, and they have firmware, and have successful connection.

You can install vmware to have linux on windows platform

You can also try to downgrade with this exe:

When I try to downgrade, I get this error:

Maybe in new version, for successful connection, I need to enter any additional commands?