HL8548-G hangs sending body AT+KHTTPPOST


I am developing a product based on the modem HL8548.

The device sends photos to a server through the HL8548, via http message. The device is working fine, most of the images are sent correctly to the server.
But there are about 3% of them that don´t arrive. I have analyzed the problem in depth, and I have found that the modem hangs in the middle of sending the failed images. Then, the modem doesn´t response until it is reset by hardware.
The voltage of the HL8548 seems good at all times.

Could you help me please with this issue? Why could the HL8548 hang?

I have been trying to get additional information through the DEBUG_TX and DEBUG_RX, AT+TRACE active, but received just a byte from the HL, I don´t know why. I don´t find anywhere the programs 3G FTT and Mobile Analyser. Could these pins give me more info about the problem?

More info:
Model: HL8548-G
Revision: RHL85xx.
Software Version: 07
Serial Number: HE724402470610


Hi fabianburillo,
The firmware is really too old, could you help to upgrade to firmware ?

For Mobile Analyser or 3G Firmware Trace Tool, you can contact your Distributor or submit a ticket at “Contact Us” on sierrawireless.com


Thanks jerdung,

I’m trying to upgrade the firmware but it seems I can’t use the AT+WDSD command with this firmware version:
+WDSI: (0-8191)

This old firmware can’t support WDSD command?

Then, I read I can use OneClickTool to update the firmware, via UART. I have a custom HW. I am wondered which is the UART port of the modem used to update the firmware?



Hi fabianburillo,
The OneclickTool should be used with USB port.
Please install USB driver at https://source.sierrawireless.com/resources/airprime/software/hl854x-usb-drivers
Download .exe file at https://source.sierrawireless.com/resources/airprime/software/hl8548-hl8548-g-hl8549-and-hl8549-g-firmware/#sthash.9ixK5O1h.dpbs


Hi Fabian,
In v5.5.14, Package local download by +WDSD is not supported yet.
+WDSD is supported from v5.14.4.0.

Thanks jerdung,

My Windows 10 PC doesn’t detect the HL8548 USB. I have tried to connect it to another PC and nothing. The USB connections of the board are correct and when I connect the board to the pc, it has 5 V in the VBUS input of the HL8548. It does not detect the USB connection even when I can see the modem on and I can successfully communicate with AT commands through the UART.

What I can be doing wrong? My OS? Is there any command to enable or disable USB, or any command to see in real time the USB connection?

Thanks again

Hi Fabian,
Please make sure that the USB configuration is correct, https://source.sierrawireless.com/resources/airprime/hardware_specs_user_guides/airprime_hl8548_and_hl8548-g_product_technical_specification/#sthash.KD7jK7o2.dpbs

You can refer this topic to upgrade your device HL8548 firmware update


1 Like

Thanks jerdung and Sierra_klin2,

I have not managed to update the firmware of the HL8548 on my PCB, because I do not have the proper hardware.

However, I have purchased a MangOH Red board with an HL8548 modem with firmware version 5.24. Then, I have repeated the same test of sending successive pictures to a server via HTTP, using a script from my PC that sends the commands to the MangOH Red via USB. And I got the same error: Suddenly, sending an image to the server fails, and the modem freezes and is not responding. So it is not a firmware version problem.

It cannot be an error in the way the commands are sent, since it is something repetitive and I have managed to upload images to the server. Anyway, I attach the command flow I use:







-> Setting HTTP addr…
+KCNX_IND: 1,6
+KCNX_IND: 1,1,0

-> Sending HTTP header…

cache-control: no-cache
Content-Type: multipart/form-data; boundary=--------------------------800559106013275992937575
Authorization: Token token=“my_token”
Accept: /
accept-encoding: gzip, deflate
content-length: 107347
Connection: keep-alive


Content-Disposition: form-data; name=“image”; filename=“testimage.jpeg”
Content-Type: image/jpeg


HTTP/1.1 201 Created
Server: nginx/1.10.0 (Ubuntu)
Date: Tue, 04 Aug 2020 08:38:22 GMT
Content-Type: text/plain; charset=utf-8
Transfer-Encoding: chunked
Connection: keep-alive
Cache-Control: no-cache
X-Request-Id: d67a037c-ed4b-48a3-8997-18b337aa3634
X-Runtime: 0.455576

+KHTTP_IND: 1,3,107347,201,“Created”

-> Closing session…
+KCNX_IND: 1,5,30

The above command flow is when the HL8548 is working properly. However, when it fails, the modem does not respond at all after sending the image, and does not respond to any subsequent commands until it is reset.

When the failure occurs, I have checked on the server that the modem stops sending. So, it is not a problem on the server.

Investigating in depth, I have come to the conclusion that it may be a bug in the HL8548 related to coverage and (at least) sending via HTTP. Repeating the test several times in environments with worse and better coverage, trying to send 100 images in a row to the server, I have come to the conclusion that, having a coverage (getting RSSI with AT + CSQ command) lower than 15, the HL8548 can freeze up to 30% of the time. However, with exceptional coverage (RSSI around 30), it never seems to hang.

I need help with this problem. It is a reality that the hl8548 hangs regardless of its version. Why? How to avoid it?

Thanks for your time