MC8090 Getting started with HIP/CnS

Hi everyone

I’m trying to do a linux program that communicates with MC8090 witn CnS commands. I already worked with AT commands but I want to test HIP protocol.

My first problem is I think I need to change the configuration of the modem with:


But I can’t, it gives me just “ERROR” (also others configurations with this command).

I don’t know if this is necessary so I tried to send the very first CnS command in USB0 like this:

request[0] = 0x7E;
      request[1] = 0;
      request[2] = 10;
      request[3] = 0x2B;
      request[4] = 0;
      request[5] = 0x00;
      request[6] = 0x01;
      request[7] = 0x01;
      request[8] = 0;
      request[12] = 0x05;
      request[13] = 0;
      request[14] = 0;
      request[15] = 0x7E;

It suppose to return Firmware Version but it does not. I don’t have any response.

I don’t know if the command is ok. Is there some example code that I can compare?

Also, Can someone explain to me what is the difference of HIP messages and CnS message? How do I know which HIP messages are extended or standard?

Thank you all

PS.- Sorry for english grammar.

Hi Sanik,

Welcome to the forum, please find my comment below:

    This command is level 2, you need to enter unlock code first (!ENTERCND), check with your distribator for info.
    However, it only takes care SIM Tool kit feature, nothing to deal with CnS.

  2. To get firmware info, try:
    7e 00 0a 2b 00 00 01 01 00 00 00 00 02 00 00 7e

  3. Please refer to CnS guide for more the protocol info and HIP vs CnS.

Hope it helps.

Hi lotam

Thanks for the answer!

  1. I though maybe it was needed because the parameters says:
    0 = Disable
    1 = Enable for CnS interface (AT disabled) <–
    2 = Enable for AT interface (CnS disabled)
    But certainly is for SIM Toolkit. I will contact my distributor anyway.

2-3) I tried the command but still give me no response. I will check better my code and check the documentation again.

Is there some configuration or condition in order to begin to send CnS commands? I need to open ttyUSB0 port right? (The first of the Sierra USB modem converter)

Thank you again

------------ Edit ----------
I checked my code and I was reading my answer wrong! … Now I see the response.

Thank you again :slight_smile: