I have come up with a problem of installing the QMI SDK and I am stuck in the process of 'Building the SDK Executable' , where I could not find any pkgs.mak file inside the pkgs directory to clean and build.

Any help will be highly appreciated.

Thanks in advance


Have you tried download that related file from “terchip” website ?


 Thank you so much for your reply. It would be great if you could provide me the link that you have mentioned in the post.

  Thanking you once again.


That link is :


In order to download any files from this website, you must register with a valid “company” email and cannot use our normal yahoo or gmail.



  Thank you so much for the reply.


Have a nice day. You could download that related files from “Sierra Source” website as below:


My previous email, you could sign-up with normal yahoo or gmail email, BUT for this “Sierra Source”, you must have a “valid” company email instead.



    Thank you once again. But, for me I have already downloaded the package from both the sites and   I am halfway in the process of installation, I am following the developer's guide to install the package but, in the middle I am stuck with these commands :

   [b]clean then build: make –f pkgs.mak complete
   clean: make –f pkgs.mak clean
   build: make –f pkgs.mak

   where, I can't find any file named [b]pkgs.mak[/b]  in the directory of[b] pkgs [/b]to run this commands on.

   Your help will be highly appreciated.

   Have a nice day.


I’ve gone through that manual (Application Developer’s Guide - LINUX QMI SDK) and look for that information and believe referring to below: Building the SDK Executable.

I believe that "“pkgs.mak” is there because this SDK is referring to Sierra Linux QMI SDK (SLQS) and that file is “slqscompile.mak” and believe “pkgs.mak” is only an example.

Sorry, I’m not expert enough on linux, but from my point of views I believe that the file.



  Thanks a lot for the reply. Yes, I have already tried with the slqscompile.mak with the commands in the begining but everytime I have found this error. :

      [b]  make: *** No rule to make target `clean'.  Stop.[/b]

      I have also tried putting with and without the file extension, but, both did not work for me.

            Thanks for your help.  

            Thanking you once again



I coundnt make slqscompile.make beacuse i have PC with ubuntu but i dont know how i can compile that
also i make Gobinet and gobiserial but i cant find [qcqmi
please guide me