MC7710 Fujitsu E753 Windows10 Treiber Problem

Hello @all,

which driver must i install to run the MC7710 on Windows 10.

I have tried the original from Fujitsu and the USB Drivers Build 4277 from

Thank You

Denis B.

I don’t have Windows10 here :frowning:
But let me know whether you are facing any issue with these drivers…


Hello Rex_alex,
I have issues with Windows 10 as well. I wanted to use MC7710 with my Lenovo X230 with Win10. Issue is that when I upgraded straight from Win7 with drivers installed Win10 could see old drivers. When I refreshed Windows 10 to factory reset (clean Win10) I can only see Sierra Sensor in manager. There is no uknown device like in Win7/8/8.1. When I tried drivers 4277 and 4208 (even in compatibility mode) they do not work. Skylight does not see the device and Device manager shows only mentioned earlier Sierra Sensor.

Ok so when you say Sierra Sensor - Which one are you seeing? There are a few different interfaces (Assuming that’s what you mean by sensor?) that you can see usually.

It almost sounds to me like its the Win10 MBIM only configuration problem again…
Is the only interface you are seeing a network interface?

If it is, look at this thread and see if the fix listed there for windows helps and let us know. :slight_smile: