MC7710 cold boot problem [SOLVED]


#1

Hi,
I have a MC7710 cards which with the latest firmware >=year 2012 is not functional after cold boot - if it was plugged in USB before power-up!
I am running Linux, so loading sierra.ko should be enaugh to talk to it over serial, but after cold boot it is just silent.
Also I did test with multiple cards on different hardware with different OSes (all Linux based so I can’t tell anything about windows).
Evidence is pretty solid, below is info from one of the failing cards.
Downgrading firmware is not an opion, because people are getting OTA upgrades.
Any suggestions?

ati
Manufacturer: Sierra Wireless, Incorporated
Model: MC7710
Revision: SWI9200X_03.05.19.04ap r5475 carmd-en-10527 2012/09/17 17:57:14
IMEI: 358178040035844
IMEI SV: 13
FSN: CCQ3561047710
3GPP Release 8
+GCAP: +CGSM,+DS,+ES


#2

Hi,
I tried with MC7710 with same FW version (3.5.19.4), but I cannot repeat this problem with Ubuntu PC.

Seems like even USB enumeration is not happening, may I ask are you testing MC7710 on your application or Sierra dev.kit?

Can you check the power sequence and W_DISABLE pin behavior in case you are not testing with Sierra dev.kit?
Also, the syslog/dmesg may tell some hints…

Thx


#3

I am not using dev kit, just retested with some lastest Ubuntu running kernel 3.8.0-19-generic, also this is not just one box or one card.
To reproduce, just plug the mc7710 into box, which does not have power coord attached (press the pwr button to discharge caps to be shure no power left there), then plug the power cable back in, start the OS and verify. btw, this does not happen on Windows, maybe driver issues some special/other commands there other than the sierra_net does on initialization?
USB endpoints are enumerated fine, also first (0) serial channel is spewing out some data as usual (firmware is working), but nothing else works, serial on channel 3 is not answering, also it is not a SYNC problem I saw somewhere discussed (dmesg is empty), I can prevent sierra_net from loading and serial still does not work. I if replug my card everything works fine.
Is there anything I can test for you?


#4

My observations with the new firmware
In win 7 (on Dell laptops) the AirCard Watcher & drivers (R11.3.1109.0 build 3228) can wake up the card from power up and use it for internet connection.

However, the Qualcomm diag port does not work. When I try to use a network analyzer usign QC diag it can’t connect. Only after toggling the wireless switch the card works as expected.

With newest Ubuntu 13.04 the machine recognizes the card, but can’t really get connection. Have not debugged it deeeper.


#5

I suggest you update to the latest FW 3.5.23.2. According to the release notes:
“Fix AT port unresponsive if device is powered prior to enumeration”

I also experienced this problem but I don’t see this problem with the latest FW.


#6

Thanks, the latest firmware fixed this issue.