MC753X Doesn't Work In Linux After Booting Into Windows 8.1

I have ran into a problem multiple MC Series cards (MC7535 & MC7534). I have working MC7535 card that I took from a Panasonic Toughbook that works fine in Windows but when booting into Linux (Fedora, CentOS, Ubuntu, or Arch Linux) the /dev/ttyUSB* never gets created. I have tried each of these operating systems as they all seem to come with a different Kernel and ModemManager (with Arch Linux being the most up to date).

I then purchased a brand new MC7534 which arrived today and installed and directly booted into ArchLinux upon which /dev/ttyUSB1, /dev/ttyUSB2, and /devttyUSB3 all appeared and I was able to connect to the Mobile Network without any configuration changes done on the operating system. I tested rebooting the system multiple times and each time the card functioned without an issue. I then shutdown the system removed the hard drive and replaced in with a Windows 8.1 OS upon which the modem connected directly to the Mobile Network and functioned fine. I shutdown the system once again and removed the hard drive and replaced it back with the copy of Arch Linux (which worked before) and the modem no longer functions and doesn’t create the /dev/ttyUSB* devices anymore.

I have seen other posts on this forum complaining about the same issue but no resolution. I fear the modem is stuck in a configuration state that needs to be reset but I am not sure how to do this. Thoughts?

I suggest you to contact your distributer and come via support front in this case…