MC7700 AT Commands in Linux


#1

I apologize for being totally at the starting point here.

I attached my MC card to the dev board and connected that via USB. I have /dev/ttyUSB0-/dev/ttyUSB6, which showed up when the card connected.

I’ve tried opening each of these in cutecom at 115200 baud, 8 bits, 1 stop bit. I tried sending “ATI” to get info from the card.

None of the serial connections appear to be responding. Some of them hang, some of them don’t hang but don’t respond with any information.

All the documentation seems to assume that I know how to send AT commands. Am I doing it wrong? Is there a step I’m missing?


#2

Hiya,

You might have a driver problem in linux. Is there anything in the app notes or other doco that says which drivers/kernel modules need to be installed?

Try this:

  • Log into your linux box
  • unplug the dev board
  • type
tail -f /var/log/messages

to tail out the system log (syslog) messages

  • plug in the dev board
  • see what is displayed in the log.

The log entry should show you some info about what’s just been plugged into the USB. If the Linux Kernel can find a driver, you’ll see which com port (ttyUSBxxx) your module has been connected to, otherwise you’ll probably get an ‘unrecognised device’ message of some sort, with some debug info to help sort out the problem.

Note: depending on your linux distribution, the syslog messages may not be on /var/log/messages.

If you’re still stuck, post the results of the USB connection here and I’ll have a look at it with you. Unfortunately I don’t have one of these devices myself so I can’t tell you immediately how to set them up.

ciao, Dave