I’ve a problem with my MC7455 under Windows’s environment already (only) “QDLOADER MODE” which means waiting firmware to be flashed. Based on all related information could be resolved through LINUX/UBUNTU via third party tools (QMI-FIRMWARE-UPDATE). I had changed O/S from Windows 10 to UBUNTU 17.04 where MC7455 detected under “lsusb” whilst only “/dev/ttyUSB0” was shown. I’ve already installed “qmi-firmware-update” and scared to test about. I would like get any help especially on “HOW-TO” to resolve these issues.


I’ve tried third party tools (qmi-firmware-update) on DELL E7240 running UBUNTU 17.04 where results as below:

zabo5515@zabo5515-E7240:/sierra$ sudo qmi-firmware-update \

-t /dev/ttyUSB0
[sudo] password for zabo5515:
error: error creating device: HDLC trailing control character not found

Got above errors and how to resolve these all and much appreciated.

The device is probably in a debug mode. This looks similar to “QDLOADER MODE”, having a single serial interface with the bootloader ID. But it does not support the firmware upload profocols. You can run the ramdump tool from the SDK to verify.

Hello DL5162

Thanks a lot. I’ve tried “ramdump” as mentioned where lots of “BIN DATA” were generated and don’t know how to analyze. I notices “/dev/cdc-wdm?” was not generated along with “/dev/ttyUSB0” that why “QMI-FIRMWARE-UPDATE” shows an errors. Any idea how to resolve these issues.

Maybe you are at the state fo the modem,when it detects improper SBL data - if you can “git” the latest qtools package ( at line with “state 5” - use translator.
qtools are a little tricky because of if you use incorrect loader (you must rename correct loader - follow instructions) it blocks communication and need to restart.
Please try it and send any info.



thanks a lot for mr. bolkoo and anyway I would like to stop here because so tricky. Actually I’ve another working EM/MC7455 modules on Windows/Buntu environments. I believe that problematic module (MC7455) already a ‘factory death’. :frowning: :frowning: