MC7330 QDLoader mode

Hi,

I have 1pcs MC7330,QDloder port presented only,cannot be JTAG erase or reprogramming.

The JTAG Trace32 reported: Verify error at address ZSR:40000001.

What’s the ZSR:40000001 here means ???

Best reagrds!

Hi,
As per my understanding this can be some memory corruption.
How you performed JTAG? any sierra expert help you? I will suggest you to get help from sierra technical team for proper support in this case.

-Alex

Hi,

I have the same problem with my MC7455 (bought from mainland of China) where “QDLoader Moder” port was created inside windows “device manager” which means that module was brought up at “bootloader mode” and waiting for “firmware” to be flashed. With current sierra firmware firmware flashing tools (fdt.exe), we don’t have any options to eliminate “modem status” which means that module was bricked. I’ve returned both my MC7455 to factory for firmware recovery. Based on so much information about ‘AT’ commands, to brick that sierra wireless module is so easy by set to “boot and hold” … Am I right ?

Hi Alex,

Yes,i got some help from sierra techical support for the JTAG.
I just want to know what’s the ZSR:40000001 meanning,to which related address on the flash memory or MDM?
Thanks!

Even i have no idea about ZSR:40000001 :frowning:

Hope only sierra expert can help you …

-Alex

You mean at!boothold? Maybe. I don’t know what the official tools are doing, but you might be able to flash it with the QMI SDK stuff. Or use the newly created opensource method: cgit.freedesktop.org/libqmi/log … are-update
I have not tested it, but I think you might be able to flash while already in QDL mode.

Hi,

I’ve an experience with my MC7455 (2 units). I’m not so sure for the rest because both are bought from China and someone did mentioned that modules (MC7455) come from China are for “testing” purposes. So weird for me because I’ve EM7455 as well and bought from China too but working fine. Yes, on windows environment sierra wireless has tools (fdt.exe) to flash firmware on particularly MC/EM modules via “bootloader mode” (QDLoader Port). BUT, if this the only established inside windows “device manager” then firmware flashing doesn’t pass through because that tool (fdt.exe) always checking for “modem status” where couldn’t be eliminated. I haven’t tried on linux environment. Based in google searching, especially for Sierra Wireless Broadband modules, if already at “bootloader mode” which means that module was bricked and has to return back to “factory” for firmware reprogramming.

fs1, thanks for pointing out that tool. I did try and get my device out of bootandhold using it, but no luck. It compiles with a little nudging. It did respond a little to the tool, but no success in flashing or getting a working device.

Try #Ilostcount I was successful in recovering. I used the opensource tool and did the steps manually, putting it into QDL mode, then flashing in qdl mode, specifying everything. Wahoo!

Wow!!! that sounds great…

Let me know which tool you have used to recover :slight_smile:

-Alex

https://forum.sierrawireless.com/t/mc7330-qdloader-mode/8937/1

You have to compile it as it’s literally not even in the trunk of the project yet, let alone distributed anywhere. But if did recover my device when literally everything else failed. If you’re stuck I do have a terrible debian package I built I could share that would get you a binary you could run on ubuntu. I ran with:

sudo qmi-firmware-update -v -b -s 2:27
wait for reboot
sudo qmi-firmware-update -v –update-qdl -s 2:28 –firmware-version 02.20.03.00 –config-version 002.017_000 –carrier Generic SWI9X30C_02.20.03.00.cwe SWI9X30C_02.20.03.00_Generic_002.017_000.nvu

Replace firmware files and version as needed. Pass your device with -d or -s as I have done. Use lsusb to find it.

Note that the --carrier, --config-version or --firmware-version are only for the --update command; they are ignored for --update-qdl. Also, you no longer need to pass them even with --update, as they will be automatically detected from the image files. See qmi-firmware-update --help-examples

And really, the easiest way to refer to a device is with “-d vid:pid” as even “-d 1199” will just work as long as you don’t have more than one sierra device plugged in.