MC7430 stuck in QDL mode

I have an MC7430 showing up in QDL mode under Linux, and I would like to get it into a working state. In an attempt to recover the device, I have compiled the latest available version of libqmi to use the qmi-firmware-update utility but have not had success when trying to run the program. I have also complied and loaded the Sierra GobiNet and GobiSerial drivers, and blacklisted the qcserial and qmi_wwan drivers (not while simultaniously trying to use libqmi) with similar results.

The output of lsusb
Bus 001 Device 003: ID 05c6:9008 Qualcomm, Inc. Gobi Wireless Modem (QDL mode)

I’m unsure if it is supposed to be showing up with this mid:pid as I have read on these forums that this is the generic Sierra device id.

My system:
uname -a
Linux ubuntu 4.10.0-28-generic #32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Is there any way to get the device out of QDL mode? I have also tried communicating with the device on Windows 7 using the official Sierra driver package for mc74XX devices with PuTTY and that Russian Huawei Terminal utility. Using the Sierra drivers it still showed up as QDL_BULK, and was in a state where I was unable to communicate with the device.


Here is some additional information. When I plug the device into a board running OpenWRT, this is what shows up in dmesg:

usb 1-2: new high-speed USB device number 7 using xhci-hcd
usb 1-2: New USB device found, idVendor=05c6, idProduct=9008
usb 1-2: Product: QHSUSB__BULK
usb 1-2: Manufacturer: Qualcomm CDMA Technologies MSM

So, pretty much the same situation. On Windows the device is seen as a Qualcomm HS-USB QDloader 9008 attached to a COM port.


I believe you should use tools from latest SIERRA SDK instead of third party qmi-firmware-update. Why ? Because I had the same problem as yours for my MC7455 where under windows environment already at “Bootloader Status” which means that device is waiting for Firmware Update. With current windows Sierra Firmware Update Tools" couldn’t be resolved. I had tried using “qmi-firmware-update” in Ubuntu ad been mentioned by other users but no luck for me where my device (MC7455) was totally faulty and couldn’t recovered anymore. I believe owner for “QMI-FIRMWARE-UPDATE” could provide much more information on “HOW-TO” for this tools.

FWIW, my experience using the libqmi firmware update tool (on Arch Linux) has been nothing but perfect with an MC7455. There are a lot of examples provided in the help, including manual steps if you decide to do it that way.

BTW, I’ve never attached my MC7455 to a Windows machine, and never will. :slight_smile: