MC7304 prevent data usage


#1

Hello,

the modem MC7304(edited) uses mobile data.
To the background, we are using the modem on a debian with smstools to send SMS.
This works fine. There is only one interface listed, eth0 for ethernet. But there the sim card seems to use mobile data and produces costs. The sim card is an m2m sim card.

Is this a known issue?

Best Regards
ArmMa


#2

Check AT+WDSC? and see what +WDSC: 3,x is. If x is not 0, you can set it to 0 and check if you still see the data usage. How much data usage do you see?


#3

The data usage is not consistent. Only once or twice a month with a couple of kbytes.
I will check the option and will give you a feedback as soon as it is fixed.


#4

@ajoseph
I miss read the model of the modem. It is a older one, an MC7304
The at command is not working with it. Do you have any ideas?


#5

The MC73xx modems do not support the command. The data you’re seeing maybe GPS XTRA downloading assistance data. You can disable it, if enabled.
AT!ENTERCND=“your password”
AT!GPSXTRADATAENABLE=0
AT!GPSXTRATIMEENABLE=0
AT!RESET

AT commands guide is available at https://source.sierrawireless.com/resources/airprime/software/airprime-em73xx_mc73xx-at-command-reference/


#6

AT!GPSXTRADATAENABLE?
This was already on 0
So I checked for AT!CUSTOM? which gave me this:
!CUSTOM:
GPIOSARENABLE 0x01
GPSENABLE 0x01
GPSLPM 0x01
NMEAENABLE 0x01
GOBIIMEN 0x01
USBSERIALENABLE 0x02

After AT!CUSTOM=“GPSENABLE”,0

It gave the output
GPIOSARENABLE 0x01
GPSLPM 0x01
NMEAENABLE 0x01
GOBIIMEN 0x01
USBSERIALENABLE 0x02

So I guess this was the Problem, or did I changed something else?


#7

You will have to set XTRA DATA and TIME to 0. Removing GPSENABLE is also fine as you are not using GNSS.